10

<snark superfluous>Good to see old traditions again,</snark> since just like last year, Winter Bash is borked for me:

Oops! Something Bad Happened!

I cannot login on the https://winterbash2019.stackexchange.com site as I get aforementioned error, and while trying to wear hats, I get a nondescript "An error occurred while changing the hat" message (which I'm sure is entirely unrelated ;-P).

You may want to look into this.

  • Can you log in to stackexchange.com? (Just a hunch that it may be related, if you can't.) – Shadow Wizard is Ear For You Dec 10 '19 at 8:52
  • 1
    I am logged in on stackexchange.com. – deceze Dec 10 '19 at 8:55
  • I don't really feel like logging out of everything, but I've logged in on another browser to stackexchange.com and then tried to sign into the WB2019 page → same error. – deceze Dec 10 '19 at 8:57
  • Any software on your system that prevents certain types of connections or software? – Luuklag Dec 10 '19 at 9:17
  • @Luuklag No. I even explicitly tried disabling content blockers. – deceze Dec 10 '19 at 9:18
  • @Eran That shouldn't influence anything, and I'd like to keep my history thankyouverymuch, and if that is the cause of any problem then SE should fix it, since they can't expect everyone to clear their history. – deceze Dec 10 '19 at 9:19
  • 2
    I suppose the hats just don't fit onto the headphones ... :) – Jonas Wilms Dec 10 '19 at 11:55
  • 1
    @Jonas That actually is an issue, I'd like to ask for more inclusive headgear next year! – deceze Dec 10 '19 at 12:04
  • An "unexpected error"? That was...unexpected. – Robert Columbia Dec 10 '19 at 13:45
  • So, anyone else suddenly wishing for a Swedish Chef hat? (Bork!Bork!Bork!) – Meg Dec 10 '19 at 21:44
21

Something hokey happened the first time that you tried to do something with a hat. I cleared out your data and it repopulated with the scheduled task. Can you please try to log in again?

Update: weird data situation fixed, all is working now

|improve this answer|||||
  • 1
    Any chance for gory details? ;-) – Shadow Wizard is Ear For You Dec 10 '19 at 13:36
  • 5
    Combination of user-inits on specific sites for this account in the past that went awry (leaving multiple phantom user records on those sites), those not getting cleaned up, and the network api call being used to retrieve them not filtering them out. And the WB code expecting (rightly) to get one row per account/site. – Yaakov Ellis Dec 10 '19 at 13:39
  • Sounds like my code!! lol... good thing you caught it so fast. So, you added some sanity checks to the code? – Shadow Wizard is Ear For You Dec 10 '19 at 13:42
  • 7
    May I feel special in that I was the only one with such data? Or are you currently crawling around the air vents to clean up loads of messed up data? – deceze Dec 10 '19 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .