10

When editing a post that a moderator has disabled commenting on through the standard editor (editor page, not the 2k+ inline editor), one will receive an incorrect error message upon the next heartbeat request that the question is locked and is no longer accepting edits, even though it is.

Steps to reproduce:

  1. Find a post that a moderator has disabled commenting on.
  2. Open the "edit" link in a new tab (to access the standard editor page, or /posts/[post ID]/edit. Make a few edits. (If you have <2k rep, you can just click the "edit" button - you don't need to open it in a new tab, which is necessary for 2k+ users to bypass their inline editor.)
  3. Wait some time for the page to perform a heartbeat request. You'll receive a big yellow error message indicating that the post is locked and is no longer accepting edits. This message is incorrect.

The "Submit" button is enabled, and the edit does indeed go through, but this false error message is a major nuisance. (Update: Some users are reporting that the Submit button is disabled entirely - this increases the scope of this bug.)

Another update: This appears to be happening with the answer form as well. Steps to reproduce:

  1. Find a question that a moderator has disabled commenting on.
  2. Type something into the "Answer" box.
  3. Wait some time for the page to perform a heartbeat request - you'll see a big yellow error screen that says "this question has been locked - no more answers will be accepted". This error, as before, is incorrect.
  4. Copy your attempted answer into the clipboard, refresh the page, paste it, and post it. It will go through successfully.
  • 1
    In case you're looking for a repro case, this FAQ on MSO is a good one. Should be required reading for all SE users anyway. – Cody Gray Dec 12 '19 at 23:20
  • 1
    In my case, the banner disabled the Submit button. Copying my post and refreshing the page gave me a working Submit. A quick paste and I was in – Machavity Dec 13 '19 at 14:28
  • 1
    @Machavity same here, the submit button was disabled as well. I just opened the browser's developer tools and removed the disabled="disabled" from the HTML :) – Glorfindel Dec 13 '19 at 14:41
  • Another report of it happening here: money.meta.stackexchange.com/questions/2807/… – GS - Apologise to Monica Dec 13 '19 at 23:39
4

This is fixed both for edits and for posting new answers on a comment-locked question. Thanks for the report!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .