31

Originally posted on Stack Overflow: https://stackoverflow.com/questions/59320473/stackoverflow-duplicated-layer-bug

Requirements to reproduce:

Windows 7 x64
Firefox 71.0 x64

Steps to reproduce:

  1. Go to the ask question section
  2. Write something to the title field
  3. Start scrolling similar questions
  4. Change the title field
  5. Start scrolling the similar questions again

The look you will get

  • The original MSO bug report is here. Also re-reported here: meta.stackoverflow.com/questions/392102/… – Cody Gray Dec 13 '19 at 19:17
  • I can confirm this bug when StackExchange sites are opened in Firefox 72.0.1, which as of this comment, is the latest general release. I have not seen this issue on any other websites. My temporary solution is to use a content blocker to block the 'Similar questions' area until it is fixed. Hopefully someone at SE will let us know if this is being worked on. – RockPaperLizard Jan 14 at 0:14
  • 1
    Still a problem in Firefox 73.0 (Windows) – MrWhite Feb 13 at 12:32
  • @RockPaperLizard "temporary solution is to use a content blocker" - How is that a "solution" of any kind? (Why not just ignore it? It's not a problem until you start to interact with it.) But you can temporarily "fix it" by just closing/opening the "Similar questions" dropdown. Or even just clicking off the "Similar questions" area and clicking back (although that is a bit hit & miss). – MrWhite Feb 13 at 12:51
  • @MrWhite You chose to leave out a key word when quoting what I wrote. I wrote "My temporary solution...". I prefer not to have a large UI element that does not work properly cluttering the page, and so MY solution is to remove it until it is no longer broken. – RockPaperLizard Feb 14 at 7:45
  • 1
    I'm facing the same behaviour on Firefox 75.0 (64-bit) on Ubuntu 18.04. A workaround is to click twice the little up-arrow ^ at the top right of the affected component to make this bug disappear (at least temporarily). – s.k Apr 13 at 8:25
  • 1
    Still happening Firefox 75.0 64-bit Windows 10 build 18363. Please fix. – rory.ap Apr 23 at 12:41
  • Also reported on MSO 2020-05-04. Two combinations: Firefox 75 (current for the date) and Ubuntu 19.10 (Eoan Ermine) / Ubuntu 20.04. It may or may not be an intermittent problem. – P.Mort. - forgot Clay Shirky_q May 4 at 16:12
  • FF79/Ubuntu: still problem. What a PITA this is, 9 months on from this being raised (and raised again). I don't think SO have got their priorities right in terms on UX development at all. – artfulrobot Jul 2 at 7:09
11

I am able to reproduce this running Firefox 68.3.0 ESR on macOS v10.14.6 (Mojave):

Enter image description here

It appears that it is the exact same layer duplicated over one another.

| improve this answer | |
5

I'm seeing this in Firefox 71.0 on macOS 10.13.6 posting this question:

enter image description here

The effect appears whenever I edit the question title. It disappears whenever I interact with the page in any other way (e.g. clicking on the page or leaving the browser window).

| improve this answer | |
4

A couple of notes I made while testing (Firefox 71 on Windows 10):

  1. I can only make this happen if I'm zoomed in
  2. I can only make this happen on Firefox
  3. The artifact disappears if I switch tabs or even just hide the Firefox window briefly
  4. If I turn off the clip-path style on #js-similar-questions-expandable, this stops happening entirely.

My gut feeling here is that this is a Firefox bug, although one we could possibly work around at the cost of making collapsing that list look a bit more ugly.

| improve this answer | |
  • 1
    Shog, 3 I concur, 1 I have to disagree. For me it works on 100% zoom – Luuklag Dec 13 '19 at 18:25
  • @Luuklag Do you by any chance happen to be using a high-DPI screen? – Sonic the Masked Werehog Dec 13 '19 at 18:28
  • Cant recall if I tested it on external monitor or not. Otherwise on a macbook air 2018. External monitor is a dell from this year, widescreen. @SonictheReinstateMonica-hog – Luuklag Dec 13 '19 at 18:54
  • Although there is currently no data to conclude it's a Firefox bug, if it turns out to be one, please report at bugzilla.mozilla.org – RockPaperLizard Jan 14 at 0:17
  • I'm on Firefox 77 on Windows 10. This is still an issue. – LShaver Jun 24 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .