I asked a question how to start knitting on Winterbash site.

How do I start Winterbash knitting on mobile?. One answer gave a way to use in landscape mode. It worked. But some colours are cropped out.

enter image description here

balpha's answer says:

When I built the knitting editor last year, I decided there has to be a minimum width for knitting to make sense, and the value I picked happens to be between typical widths and heights of common phone screens

When we used landscape mode, 6 colours are cropped out (3 from left and 3 from right). Desktop version has more colours.

enter image description here

Browser version : 79.0.3945.79
Screen size : 6 inches.

Since there are 2 weeks left in Winterbash, can mobile version also get all colours?

  • what is your screen resolution? Commented Dec 18, 2019 at 14:00
  • 1
    FYI, you can start knitting at 641px wide, and can only see the full pallete at 975px wide. Don't know if I will have time to fix it… Commented Dec 18, 2019 at 14:12
  • @Yaakov My screen resolution is 393x786.
    – Nog Shine
    Commented Dec 18, 2019 at 14:44
  • 1
    For the record, last year had a lot fewer colors, this wasn't an issue in 2018.
    – balpha StaffMod
    Commented Dec 20, 2019 at 12:07

1 Answer 1


I have an extremely small phone but I was able to get the entire palette by zooming out with the AA control thing (the phone also must be in landscape):

(This is Safari on iPhone SE. Hopefully something similar will work for you.)

  • I tried different methods to show all colours. 1. Enabling desktop site i.e disabling responsiveness . 2. Your method. My browser on Android phone doesn't have zooming in option but after overriding zoom out, I tried to see 3 more colours. Still some colours are missing. My question is about the site with responsiveness enabled. Thanks for your response.
    – Nog Shine
    Commented Dec 18, 2019 at 12:44
  • @NogShine Does this comment conversation assist with the problem outlined in your comment directly above? --- Short (long?) version: #1: Android phone, FF. #2: Enable Mobile view (in browser). #3 Choose "Full Site" (lower right webpage). #4: Enable Desktop view (in browser). #5: Read 1st link in this comment. #6: See screenshots there. --- My phone is 3K screen.
    – Rob
    Commented Dec 21, 2019 at 23:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .