11

On Academia.SE, the color of non-visited links is blue, and the color of visited links is red:

Academia.SE link colors: blue (non visited) and red (visited)

However, on every other SE site I have visited, the color of visited and non-visited links are slightly different, but similar. Normally, they are different tones of the same color (which is also the color of the "Ask Question" button). For example, on Artificial Intelligence.SE, non-visited links are purple and visited links are dark purple:

AI.SE link colors: bright purple (non visited) and dark purple (visited)

Is the color of the links on Academia.SE an oversight (i.e., should non-visited links also be red to match the color of the site's buttons) or is there a reason for this apparent inconsistency? The first time I saw a few red links between all the the blue links, it did look like there was something wrong with those questions.

  • 4
    The SE devs are bringing all colors under the Stack design system. Several colors have shifted over the last few days on various places. Expect tweaking of settings where the colors went south. – rene Feb 27 at 15:22
  • 4
    Worldbuilding has the same weird blue/red combo - at least for the moment. So at least it's not just Academia. – HDE 226868 Feb 27 at 15:41
  • 4
    Also on mathoverflow: meta.mathoverflow.net/questions/4460/… . – Emil Jeřábek Feb 27 at 16:48
  • 1
  • 2
    This generally seems to be a problem (or a noticeable problem) on sites where the link colour is significantly different from the button colour, since the visited link colours now probably use the button colour. On sites where both are the same this likely happens too but is just not noticeable. – Christian Rau Feb 27 at 17:36
  • 2
    What I do hope is that fixing this will indeed fix it and correct it to how it was previously, rather than just unifying the link and button colours on these sites and thus further cutting down on the few bits of unqiue design left since the last untheming efforts. – Christian Rau Feb 27 at 17:37
  • 2
    Same on electronics.SE. Very annoying. - EDIT: fixed now, actually. – dim Feb 27 at 20:08
10

This should be fixed now.

By default, most themes inherit the primary color for question links. However, approximately 20 or so themes choose a different color for their links (for historical reasons), and in our smoke tests we weren't able to catch :hover and :visited states. A refactor to rely more heavily on the primary color broke this recently, but they've been restored.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .