15

It might be related to the recent SEDE outage but I'm unable to login to SEDE via Stack Exchange Open ID. When clicking the 'Log in using Stack Exchange' button, I get an error message

No OpenID endpoint found.

enter image description here

  • Login using Google works :) – DavidPostill Feb 29 at 21:53
  • Hmm, not sure why this isn't working, we'll take a look – Taryn Feb 29 at 22:52
  • I get a different error now: Web request to 'openid.stackexchange.com/openid/provider' failed. – Martijn Pieters Feb 29 at 23:50
  • 5
    Hey all, there’s something wrong with the redundant app setup in NY to get things working for you all, but I can’t see what it is after looking for a bit tonight. Apologies it’ll likely be another day while we either get CO up or fix NY. This week has just kicked our butts and between hardware failure and gravity-related accidents, we’re not quite back to 100% yet. Thanks for bearing with us, we’ll get it all back working as soon as possible. – Nick Craver Mar 1 at 2:49
  • 2
    "gravity-related accidents" Well, now my interest is piqued... – Cody Gray Mar 1 at 4:24
  • @CodyGray Someone might have fallen down the stairs - it's been a really rough week. – Taryn Mar 1 at 11:49
  • @NickCraver Thank you! I guess NY refers to a server cluster located in New York. What does CO refer to? – WXJ96163 Mar 1 at 13:44
  • 1
    @WXJ96163 Colorado: en.wikipedia.org/wiki/List_of_U.S._state_abbreviations – Glorfindel Mar 1 at 13:44
  • @Glorfindel can you please test logging in now? – Taryn Mar 2 at 12:34
  • @Taryn works like a charm, TYVM – Glorfindel Mar 2 at 12:34
11

Okay sooooooo this wasn't related to the outage or the move or the redundancy or any of that. It was only close in timing.

You know how we said we were going to turn off TLS 1.0 and 1.1? Whelp, that went live on our load balancers on February 25th (6 days ago). It turns out SEDE was still doing this because it had:

<httpRuntime targetFramework="4.5"/>

This little switch controls a lot of things, including what the default TLS protocols to use are. It wasn't allowing TLS 1.2. This was just fixed for everyone using SEDE by re-targeting to .NET 4.7.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .