Over the past few weeks, using 64-bit Microsoft Edge 44.18362.449.0 on Windows 10, I've had occasional problems where the page would display initially, clear itself and then show the following

This page is having a problem loading

One URL which I've seen cause this problem when I've tried it several times with Edge, but not with 64-bit FireFox 73.0.1 on Windows 7, or 64-bit Google Chrome 80.0.3987.106 on either Windows 7 or Windows 10, is https://math.stackexchange.com/search?q=%22a%5E2+%2B+b%5E2%22+p+4 .

Also, on at least 6 or 7 occasions, I was editing an answer using Edge when it just exited immediately, treating it as if I had canceled the edit, so I lost my changes. Note that every time this happened was when I tried to type the $ symbol to specify some MathJax text. In particular, this has been happening with posts on Math SE, with this being the only MathJax enabled site I've been posting on during that period.

Note both of these problems have only ever occurred where MathJax is involved. I estimate I've been using Edge with non-MathJax pages for about one-third of the time, enough to make it very unlikely that use of MathJax is just a coincidence. Also, note there's MathJax on the search page results of the URL mentioned earlier.

I've used FireFox far more for creating and editing questions involving MathJax, with no problems like I've described occurring. Over the past few days, I've given up on using Edge for SE sites and, on my Windows 10 machine, have been using Google Chrome only instead, including for viewing & editing posts with MathJax. Likewise, I've never encountered similar problem with Chrome.

I'm fairly certain the problem is just with Microsoft Edge rather than anything to do with SE, which is why I am using the tag instead of .

According to Microsoft Edge 79 to Use the Chromium Browser Engine, the version of Edge I'm using is not using the Chromium engine but is, instead still using Microsoft's proprietary EdgeHMTL. Thus, since the latest version of Edge is not installed by default, as pointed out in TheWanderer's comment, this problem might go away if I upgrade to this latest version.

Although I only saw with Edge, has anybody else has encountered any similar type of problems on any other browsers? Also, although perhaps upgrading Edge will solve it, does anybody know of or has found a solution or work around?

Update: I've downloaded & updated Edge now to the latest beta version of 80.0.361.62, with this using the Chromium engine. The problematic URL I listed above works properly with this version. I'm going to try using it for a while to see if the browser still fails sometimes with MathJax handling, or if it will now always work properly instead.

  • 2
    The Chromium-based version of Edge is currently 80.0.361.62 (the version of Chromium it's based on). It's also not installed on Windows by default yet. I'm pretty sure you're still using the old Edge. Commented Mar 2, 2020 at 10:49
  • @TheWanderer Thanks for the feedback. You're correct. I mistakenly used Chrome's version when I commented on version of Edge, which is actually much less than the minimum of 79 that I'm interested in. I've updated my answer, including referencing your comment. Also, I'm going to find out how to get this latest version and try it to see if it works better. Commented Mar 2, 2020 at 19:58
  • 1
    search the app store for Edge and there will be a banner in the search results linking to the beta installer. Commented Mar 2, 2020 at 19:59
  • 1
    @TheWanderer Thanks again. As you suggested, I've downloaded & installed the latest version of Edge. I've updated my question above to indicate this version behaves properly with the one particular problematic URL, and I'll try it to see if continues to behave properly in general. Commented Mar 2, 2020 at 20:14

1 Answer 1


It's now been just over 3 weeks since I upgraded Microsoft Edge to the latest version of 80.0.361.69, which uses the Chromium engine instead of the original Microsoft's proprietary EdgeHTML engine. Based on roughly how often I had occurrences of the 2 problems I mention in my question and my usage of Edge since then, I would've expected to have had about 20 to 30 problems occur. Since I've had none, this gives me high confidence this latest Edge version doesn't have those problems.

Although this version of Edge is technically a beta version, note I've had no problems using it, although I also haven't done anything particularly fancy or made any attempts to do anything which I could reasonably expect might cause issues. Also, I've not noticed any particular difference in speed, but I have a relatively new & fast computer (has an AMD Ryzen 5 1400 Quad-Core Processor, 3.20 GHz, 16.0 GB RAM, 384 KB L1 cache, 2 MB L2 cache and 8 MB L3 cache). Appearance wise, it's basically the same as before, with the main visual difference I've seen is that the display change showing you've upvoted a comment is much more prominent than before.

For anybody who is using an older version of Edge and wants to upgrade, you should be able to do this at https://www.microsoft.com/en-us/edge#HW02a3je1Hrv6urc.97 .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .