22

I'm trying to download a data portability export archive for my account.

I submitted my original request via https://stackoverflow.com/legal/gdpr/request on Jan 22 18:00, it began processing Jan 22 18:14, and on Mar 3 12:13 UTC I finally got a confirmation that it had finished and was available for me to download.

However, when I tried to download it, once I click "Click here to download a copy of your data" on the page linked to in the confirmation e-mail (as well as from the "Reference" number on the request page), all I get is https://stackoverflow.com/error?aspxerrorpath=/legal/gdpr/request/GDPR-P20200122-XXXX/download (sanitized here) which says:

Oops! Something Bad Happened!

We apologize for any inconvenience, but an unexpected error occurred while you were browsing our site.

It’s not you, it’s us. This is our fault.

Detailed information about this error has automatically been recorded and we have been notified.

Yes, we do look at every error. We even try to fix some of them.

It’s not strictly necessary, but if you’d like to give us additional information about this error, do so at our feedback site, https://meta.stackoverflow.com.

I tried several times to download the archive, but got the same error each time.

I also tried making a brand new data access request, which finished reasonably promptly (a bit over ten minutes) but which gives the same error message when I try to download it.

  • 2
    For what it's worth, I'm getting exactly the same error message. – sempaiscuba Mar 4 '20 at 20:33
  • 2
    not really sure that the usual "sarcasm" found in many error messages on the network is very appropriate when law-regulated activities are involved, but I guess the standard error page was reused here too. – SPArcheon Mar 5 '20 at 9:26
  • Have you been able do download the archive, or have you heard any more about the cause of the problem? – sempaiscuba Mar 9 '20 at 21:55
  • 4
    We found an issue on our end with archive downloads. A fix is in development, and we'll respond to this post once it's been deployed. – Adam Lear Mar 10 '20 at 23:52
12

Apologies for the problems here, there have been a couple of issues that we’ve recently addressed;

  1. One of the databases queried for portability and erasure requests was having issues due to its size, the structure of its tables (CCIs) and long-running queries due to the nature of the queries - notably scanning data across all time. That meant we had many requests sitting around for a while while we rectified the underlying issues. We’ve done that by culling and tuning the worst offending tables and re-kicking the failed requests
  2. Any GDPR portability request that resulted in a large enough file would result in a non-seekable response stream that would fail when we tried to write a ZIP file to it. That meant an error page upon downloading. We’re now buffering the response prior to sending it out over the wire which addresses the issue.

Again, our apologies for the inconvenience - the first problem was a difficult one to solve as it had to be done without taking things offline which meant an abundance of caution along the way, that took time and co-ordination to get right.

If your portability requests have expired then feel free to re-submit and they’ll be available in short order to re-download.

  • For some reason, the resulting zip file has been collapsed into files, as in no folders. cdn.discordapp.com/attachments/628507458910027777/… – Zoe the 1337 Princess Mar 11 '20 at 12:51
  • Never mind, Linux thing. unzip in the terminal works. You might wanna consider changing the paths to forward slashes instead of backward. Windows supports both, but it breaks regular unzipping on at least Linux and Mac – Zoe the 1337 Princess Mar 11 '20 at 13:15
  • 1
    Good call, testing a tweak to that now – Dean Ward Mar 11 '20 at 13:43
  • FYI I'm getting "Oops something bad happened" again from a GDPR request that completed just now. – GS - Apologise to Monica Apr 4 '20 at 21:41
  • @GS-ApologisetoMonica thanks for the heads up. It’s some quirk with recent our port to .NET Core. I’m not around next week but have pinged the team to take a look – Dean Ward Apr 4 '20 at 22:13
  • @DeanWard it's fixed now, thanks! – GS - Apologise to Monica Apr 8 '20 at 7:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .