15

When moderator is trying to open timeline of this question, system redirects to the error page.

enter image description here

But regular members can open it.

8
  • what browser and OS? Have you tried to open timeline from the same browser/OS using incognito/private mode (which reproduces how it would work for a user that is not logged in)?
    – gnat
    Mar 5 '20 at 7:31
  • 1
    @gnat Firefox. Same in safe mod. Can open if not logged in. Mar 5 '20 at 7:37
  • 1
    @gnat, Chrome in Win 10. Why do you think browser is important for server-side error?
    – Qwertiy
    Mar 5 '20 at 8:12
  • @Qwertiy I asked to quicker preempt inevitable questions about that
    – gnat
    Mar 5 '20 at 8:15
  • 2
    @Qwertiy the browser might not support certain things that are crucial, e.g. it might ignore/omit the fkey parameter, not store session cookie properly etc, which can lead to internal server error. In this case looks like the error is indeed purely server side, but always worth checking the client first. Mar 5 '20 at 11:14
  • 8
    I have repro'd this and have found the exception, I'll ping the devs about it.
    – Taryn StaffMod
    Mar 5 '20 at 13:28
  • 1
    Poor devs, trampled by the blue feet ...
    – rene
    Mar 5 '20 at 14:00
  • This... doesn't seem related to a single question.
    – Catija StaffMod
    Mar 5 '20 at 15:05
11

A change went out that mistakenly prevented the Community user from being fetched from the DB. Since we assign flags and (occasionally) votes to the Community user in various cases (e.g. when a real user is deleted)... that causes a bit of a problem. :)

The fix is out in production. Thanks for the report!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .