I tried to close a question as a duplicate today, and I got the following error message:

This question does not have an upvoted or accepted answer

Screenshot of error message

In theory, there is nothing unusual here; this is a standard error that non-moderators get when trying to close questions that don't have an upvoted or accepted answer.

However, if you view the actual question, you can see that it most certainly does have an upvoted answer (with a score of +5 at the time of this writing). Why, then, does the system insist that there is no upvoted answer?

Possible factors to be aware of:

  • The question is my own
  • The question has a negative score
  • The question has a self-answer with a negative score
  • The issue persists whether I try to close as a gold tag badge holder, as a regular voter, or as a recommend closure flagger
  • The upvoted answer was originally to a different question, which was later merged into the linked question

But I'm not sure why any of these factors would be relevant.

Additionally, (since it was my question) I just temporarily accepted an answer and was then able to use it for a duplicate. This worked whether I accepted my own answer (negative score) or the other answer (positive score).

What is going on here?

(I am aware of this question, but the answer from a (then) Community Manager states that this was a one-time issue with some code.)

  • 2
    I found a question on SO (not mine, positive score) which was self-answered and had a positive, accepted answer by someone else (not the asker). I tried to VTC when the self-answer had 0 score and when the answer had negative score, and both attempts were verified by the duplicate interface - there was no error. Maybe the fact that it's your own question is throwing something off. I hope a scifi user with VTC privileges can say what they see when they try to do the same thing you're doing. Apr 21, 2020 at 1:46
  • 3
    I'm not sure how a question about Voldemort is in any way a duplicate to a question about course schedules at Hogwarts. Anyway, the question was merged with another, so that's another likely reason.
    – Catija StaffMod
    Apr 21, 2020 at 1:50
  • 1
    @Catija That's not the actual question I was trying to close. I couldn't provide a screenshot from that one because I already closed it (by temporarily self-accepting my answer). But the merging might definitely have something to do with it.
    – Alex
    Apr 21, 2020 at 1:52
  • @Catija I can reproduce. I tried to recommend closure flag a random question as a duplicate of scifi.stackexchange.com/questions/211603/…, a question with an upvoted answer, and it wouldn't let me because it "doesn't have an upvoted or accepted answer". It might have something to do with merging, since the upvoted answer was originally to the other question but was later merged in to the linked question. Apr 21, 2020 at 3:07
  • @SonictheStay-HomeHedgehog Though that would raise the question of why it works when I accept the upvoted answer.
    – Alex
    Apr 21, 2020 at 3:09
  • @Alex The message Sonic quoted says "upvoted or accepted"... so the accept may override it?
    – Catija StaffMod
    Apr 21, 2020 at 3:09
  • @Catija Yeah, but if the issue is that the upvoted answer is somehow not attributed to this question because it was originally posted to a different question, why should accepting it help? What does accepting it add that it didn’t already have from being upvoted?
    – Alex
    Apr 21, 2020 at 3:23
  • @Alex I can't look at the code. It's possible that it's checking the question for upvotes as well as the answer. If the question is downvoted, maybe it can only be a dupe if it has an accepted answer...
    – Catija StaffMod
    Apr 21, 2020 at 4:55
  • @Catija I followed the process and flagged. By the way, I don't think it's getting confused with question score, as I was able to flag a random question as a duplicate of this one, a negatively-received question with a positively-received answer. Apr 21, 2020 at 5:33

1 Answer 1


Thank you for reporting this! The additional details you provided about the factors you thought might be contributing were quite helpful. It was a pretty interesting bug to track down.

Basically, we determine if a question had been answered by triggering an update in the database if an answer had a newly positive upvote count (or if it had been accepted). We did NOT check to see if the answer's parent had changed, so when an upvoted answer got merged to a question with no upvoted answers, the update did not trigger and the question still registered as unanswered.

It should be fixed now (in the rare case that you run across this again!).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .