When I filled in the "Where do you want to work" field on Stack Overflow Careers, I wrote "Osijek, Osječko-baranjska, Croatia". Auto-magic changes this to "Esseg, Osječko-baranjska, Croatia". Esseg was the name of that city during the Habsburg Monarchy and that empire hasn't existed since the end of WWI.

I would kindly ask whoever wrote this in the database to correct it. :)

  • 2
    I apparently live in Temeshvar, not Timisoara. Nothing can be done about the database, it's Yahoo's.
    – alex
    Jan 7, 2010 at 7:38
  • 2
    @alex well, not entirely true, we can follow up with the YQL folks Jan 26, 2010 at 7:03
  • Legacy software issues? Dec 10, 2010 at 6:46
  • @alex: That's odd, considering that Temeshvar is not the name of that city in any language I know of. (Its Hungarian name is Temesvár.)
    – Marti
    Apr 5, 2011 at 18:46
  • @Marti I have no idea why it was written like that. It was annoying, nonetheless.
    – alex
    Apr 5, 2011 at 19:44

1 Answer 1


That's a problem with YQL, not with Stack Overflow Careers, which uses YQL to map free text input to places.

See the results of a search probably a lot like the one Careers uses by entering:

select * from geo.places where text="Osijek, Osječko-baranjska, Croatia"

into the console.

For which my output is:

 "query": {
  "count": "1",
  "created": "2010-01-07T07:30:09Z",
  "lang": "en-US",
  "updated": "2010-01-07T07:30:09Z",
  "uri": "http://query.yahooapis.com/v1/yql?q=select+*+from+geo.places+where+text%3D%22Osijek%2C+Osje%C4%8Dko-baranjska%2C+Croatia%22",
  "diagnostics": {
   "publiclyCallable": "true",
   "url": {
    "execution-time": "45",
    "content": "http://where.yahooapis.com/v1/places.q(Osijek%2C%20Osje%C4%8Dko-baranjska%2C%20Croatia);start=0;count=10"
   "user-time": "46",
   "service-time": "45",
   "build-version": "4265"
  "results": {
   "place": {
    "lang": "en-US",
    "uri": "http://where.yahooapis.com/v1/place/849471",
    "woeid": "849471",
    "placeTypeName": {
     "code": "7",
     "content": "Town"
    "name": "Esseg",
    "country": {
     "code": "HR",
     "type": "Country",
     "content": "Croatia"
    "admin1": {
     "code": "",
     "type": "County",
     "content": "Osje\u010dko-baranjska"
    "admin2": {
     "code": "",
     "type": "District",
     "content": "Osijek"
    "admin3": null,
    "locality1": {
     "type": "Town",
     "content": "Esseg"
    "locality2": null,
    "postal": null,
    "centroid": {
     "latitude": "45.558449",
     "longitude": "18.676491"
    "boundingBox": {
     "southWest": {
      "latitude": "45.539742",
      "longitude": "18.629290"
     "northEast": {
      "latitude": "45.572811",
      "longitude": "18.742430"


Unfortunately, it seems like the Yahoo! folks don't have much interest in fixing this...

  • 6
    Thanks. I wrote to them, let's see whether they will update it. Jan 7, 2010 at 8:02
  • Great - I tried to find you a link for submitting corrections and failed - where did you write to them? It'd be good to have that information in the answer for people who encounter similar problems. Jan 7, 2010 at 8:05
  • 7
    I wrote to them in developers forum (developer.yahoo.net/forum/index.php?showtopic=4074). It said on their Contact Us page that bug submissions should go there. Jan 7, 2010 at 8:12
  • 2
    @josip thanks for following up on this -- we've had some communication with the YQL team, let us know if it doesn't get resolved Jan 26, 2010 at 7:02
  • @Jeff It is still not resolved... I sure did give them plenty of time... :( Jul 14, 2010 at 10:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .