20

I don't know if I've missed something but as of sometime yesterday First Posts seem not to be coming in anymore. I noticed this on SFF, my main site, for example, this story identification question. A very quick look around some other sites I frequent shows similar problems, for example, this Minecraft question on Arqade.

There's also only been 3 First Post reviews on SO today which seems oddly small.

Is there a problem with the reviews?

  • 1
    On Ask Ubuntu, the last first post review was 13 hours ago, if you read the review history for the queue, you can see that is a huge amount of time to not get a first post there askubuntu.com/review/first-posts/history?page=1 This could of course be a coincidence but it does seem like a bug in the context of this post. – Mark Kirby Jun 2 at 8:12
  • 1
    Just want to confirm your observation, we have spotted the same problem on Mathematics. – YuiTo Cheng Jun 2 at 9:16
  • Same problem on EL&U – Matt Ellen Jun 2 at 9:50
  • 9
    We made a change to a query yesterday for this review queue, and I suspect there is a bug. Checking. – Taryn Jun 2 at 9:56
13

Yup, this was a bug that was introduced to the query yesterday and a fix is rolling out shortly.

TL;DR;

We've been dealing with a lot of query performance issues since we upgraded to SQL Server 2019 at the end of March. The query to populate the First Post Review Queue has been a nagging problem on some of our sites (mainly Math Stack Exchange). After poking many different things to get the query to just work faster, we rewrote it, and unfortunately screwed up the logic. We rewrote the logic again this morning and the queues should start to populate again.

| improve this answer | |
  • Already seen some on SFF. Thanks for the quick response and fix! – TheLethalCarrot Jun 2 at 14:47
  • 2
    Now the question remains: Did the performance improve with the new rewrite? – rene Jun 2 at 14:49
  • 6
    @rene We'll see. The performance issues are a bit all over the place since the upgrade. We tweak a query, then tweak it again. It's a lot like whack-a-mole. – Taryn Jun 2 at 14:50
  • 5
    Please don't whack me - I haven't been that bad, have I? – Adrian Mole Jun 2 at 15:26
  • 1
    Taryn, it was recently reported on MSO that very old posts are starting to be selected as review audits. This is causing some confusion and frustration among our reviewers. I suspect that this may be a related issue, since it only started happening recently, after the SQL update. If you have some time to spare, could you also look into this and see if you can poke it into submission? – Cody Gray Jun 2 at 20:16
  • 2
    @CodyGray it’s probably a different issue but I’ll dig and poke at things to see if I can find anything – Taryn Jun 2 at 20:17
4

Your observation is correct, though incomplete ...

  • On ALL sites, and with a few exceptions, no posts are being added to the First Posts review queues.
  • This appears to be the case since yesterday afternoon / early evening (CET).
  • There seems to be a few exceptions, such as on SO, where there are currently only 4 (FOUR !!!) completed reviews. And for one of those reviews it appears to be an audit review (so for those sites that have audit reviews enabled, those kinds of reviews still show up).

Note: Late Answers reviews appear to not be impacted.

| improve this answer | |
  • 3
    All queues seem fine but FPs aye. I didn't mean to imply only the mentioned sites were affected, they're just the ones I checked. – TheLethalCarrot Jun 2 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .