12

Earlier today I was able to view new comments and add comments. But a few hours ago, suddenly when I tried to view some new comments and clicked on the "add comment" link, the browser returned to the top of the question, and I'm unable to open up any new comments or a comment window.

I am still able to type in the answer box, although I have no reason to at the moment. Obviously, I can still ask a question.

I know that many "invisible" changes have been taking place recently. Is this a side effect? If so, I hope it's temporary.

My "home" forum is tex.stackexchange. The last comment I posted was about 3 hours ago, to this question: LaTeX citation with included chapters

Edit: I'm working on a rather old laptop: Macbook Pro, Mac OS X, Build 10K549, Processor 2.93 GHz Intel Core 2 Duo. The browser I'm using is Google Chrome, Version 49.0.2623.112 (64-bit). I have not knowingly installed or de-installed JavaScript, and have no privacy extensions installed that weren't present when the system was new.

(For various reasons the system isn't able to be upgraded, and I've had a new laptop on order since February, but delivery keeps being delayed. The main reason for unwillingness to upgrade is the fact that the last time it was upgraded, the process, carried out by an Apple tech, trashed my gmail account, which I lost, and was forced to get a new one; I don't wish to suffer that again.)

Edit 2: Shutting the system down completely and then rebooting has not cleared the problem. (Delayed after request because I'm simultaneously editing/correcting the files for a book, and had to get to a good stopping point so I can find my starting place when I resume.) I'll try again tomorrow.

Another problem has shown up, presumably concurrent, maybe or maybe not related: A click on the score for a question (in the tex forum, where I definitely have enough rep) no longer shows plus and minus values for up- and downvotes. If this is still true tomorrow, I will poke around to see if anything else has gone flaky.

Edit 3: It's morning. The laptop has been shut down, the wifi shut down, everything disconnected, but the problem persists. There are additional peculiarities noted. As @VLAZ notes in a comment, the address is augmented by # at the end when anything in the comment area is clicked; in fact, when I tried to upvote the comment by @VLAZ, that's what happens -- it's now impossible to upvote a comment.

More peculiarities:

  • It's possible to view the notifications for voting and incoming comments, but only once; after clicking on either of those icons and retrieving an item, the next click on the icon retrieves my profile, making it impossible to follow up on multiple comments or voted questions. This appears to be reset if a new browser window is loaded.

  • The review status check behaves in a new way. Instead of the small drop-down window, a full-screen display appears, with details of each option, including the icons of the last six users who have given "recent reviews". The address of this window for my "home" forum is https://tex.stackexchange.com/review .

  • When a status category is chosen, the entries still come up one by one, and it's possible to go through the full list, but the image of the entry text is very pale, very difficult to decipher, so it's necessary to click on the question to read it. (It has never been possible to click on an answer to retrieve it directly.) Since it's not now possible to post comments, this makes the review process ineffective and potentially unfair, since at least some votes can be misunderstood without a comment.

  • I find I'm also unable to upvote. (Haven't tried to downvote, but don't often find the need to.)

  • There may be more; if something comes up, I'll add it.

Edit 4: Another day, and things are getting worse.

  • The icons for the answer box (quote, code, image, ...) have disappeared, so those elements can't be marked in an answer.

  • The "post your answer" box is present, but clicking on it has no effect. The answer is lost.

Having just spent a half hour preparing code for an answer, this is quite frustrating.

Responding to various comments:

  • @user289905 suggested "Use the browser console (dev tools) (hit F12) and read any JavaScript errors." F12 has no effect except to turn the speaker volume up to max. Accessing the browser console produces a few linrs of messages in red, but there is nothing that appears to reference JavaScript.

  • @Machavity suggests installing Arctic Fox. That seems more promising, but this system is so fragile that I'm seriously concerned about installing anything major, for fear that it will fail completely. This is the only computer to which I have access until my more than 3-months overdue new laptop is delivered, or the local libraries reopen, and I have some "real" work to finish. (By the way, thanks for adding the "browsers" tag.)

If things get any worse, I will simply have to give up interacting with stackexchange, which has become my major outlet to the world. I hope it doesn't come to that.

  • Can you please provide your browser and operating system version? – Sonic the Curiouser Hedgehog Jun 17 '20 at 0:46
  • 1
    Have you disabled JavaScript, or installed a privacy extension that does so for you? – ArtOfCode Jun 17 '20 at 0:47
  • 2
    Try restarting your computer before anything else. – Jason Bassford Jun 17 '20 at 1:51
  • 4
    (I find it's an odd coincidence that this was asked so soon after Maintaining scroll position on reload — Does anyone find this useful? The requested behaviour actually being what you're experiencing, albeit not on reload.) – Jason Bassford Jun 17 '20 at 1:53
  • It's happened to me a couple of times, notably when a banner popped-up telling me I need to load java from an external site as some or other server had either been blocked or had glitched. It resolved itself quickly both times. – Tantalus' touch. Jun 17 '20 at 2:00
  • 2
    It's odd. I saw something similar yesterday. I upvoted two comments but the second one brought be to the top of the page. I upvoted a third one and it didn't happen again. Not sure how that second comment was special. Interestingly, it scrolled up because it added a # to the end of the URL. All the links for upvoting and adding a comment actually have a href="#" which if followed would add a # to the end and reset the view to top. But until now I haven't actually seen that happen, since following that link is prevented with JavaScript. There must be something wrong. – VLAZ Jun 17 '20 at 5:39
  • Chome 49 is really old (released in March 2016). Maybe use Arctic Fox? – Machavity Jun 17 '20 at 13:58
  • 1
    Use the browser console (dev tools) (hit F12) and read any JavaScript errors. Look into the Network tab: is there some resource that fails to load? – Sebastian Simon Jun 17 '20 at 17:23
  • I'm not sure if it will help or make things even worse, but maybe clearing the browser cache is worth a try – samcarter_is_at_topanswers.xyz Jun 18 '20 at 20:46
  • I heavily second @user289905's suggestion - when I've encountered this thing on SE before, it's always been because of a JS error. – CertainPerformance Jun 19 '20 at 2:34

You must log in to answer this question.

Browse other questions tagged .