9

Here is a weird thing, I simply can't change my account's password.

  • Go to your profile
  • Select Edit Profile & Settings tab
  • In the left side sub menu select My Logins
  • In the page select change password option
  • Then enter the new password to update your password.

At the profile page, "My Logins" section, when I click on "change password", it redirects me to the main site.

No error, no warning.

I can use "I forgot my password" to reset it but what's the problem here? Why is it not working?

I tried to change the password from different sites on the network but found the same result on all of them.

2
  • 1
    Looks like the option to change password from within that page is broken for a long time, it used to give error when trying, now it just do nothing which is even worse. – Shadow The Vaccinated Wizard Jun 27 '20 at 8:14
  • 2
    Related: Can't change password. It never worked for me, I had to reset my password evey time. – user361230 Jun 27 '20 at 17:12
5

Go to this site: https://openid.stackexchange.com/, and login to the account you want to change the password on. At the top, you will see a "Change Password" button. Click and change.

UPDATE:

From the post Support for OpenID ended on July 25, 2018:

Currently, https://openid.stackexchange.com/ is still on the internet, but we are in the process of completely removing it.

In light of this, I'm adding another way:

Just log out, and use the "Forgot Password" option shown here:

enter image description here

They will send you a recovery link. This is the best way I know of if the My Logins way isn't working.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .