Current behavior: When switching to full site on mobile phone, the setting is not applied to all pages of the same Stack Exchange website (tested with Google Chrome and Opera on Android).

Example: https://youtu.be/bf2GMkq38b4 (https://skeptics.stackexchange.com/election has responsiness on but afterward clicking on my profile picture on top I see https://skeptics.stackexchange.com/users/7654/franck-dernoncourt responsiveness is turned off there)

Proposed behavior: keep the setting across all pages of the same Stack Exchange website.

  • I'm afraid this might get tagged status-bydesign – mindstormsboi Jun 29 at 23:01
  • 1
    Is there a reason this is tagged as a discussion rather than a feature request? – Catija Jun 29 at 23:30
  • @Catija I wasn't sure if that was a bug, something intended or feature request. I'll retag now as a feature request. – Franck Dernoncourt Jun 29 at 23:34
  • The setting is maintained across the same site. It's just that some pages on the site have not yet been redesigned to be responsive and thus the setting does nothing, because it cannot be displayed in any other way. You experience the same phenomenon when using the mobile site when you encounter a page (such as the review queues) that do not have mobile layouts. – animuson Jun 29 at 23:36
  • @animuson thanks, shouldn't it displayed Disable Responsiveness / Full site appropriately? – Franck Dernoncourt Jun 29 at 23:38
  • The two options are mobile or responsive/full site. – Catija Jun 29 at 23:39
  • @Catija I was referring to what it displayed in the footer – Franck Dernoncourt Jun 29 at 23:41
  • 1
    Franck, there are two places that must be set the same, simply setting one or the other alone makes for some differences in the resulting rendering; also the site setting must be done for both the main and the child meta. Once that is done once the whole site should have a desktop appearance on a cellphone. – Rob Jun 30 at 5:30
  • @Rob thanks, if desktop is checked off, wouldn't it still make more sense that if skeptics.stackexchange.com/election has responsiness on then afterward clicking on my profile picture on top skeptics.stackexchange.com/users/7654/franck-dernoncourt the responsiveness should also be on? – Franck Dernoncourt Jun 30 at 6:09
  • 1
    Franck: "... wouldn't it still make more sense ...", I don't deny your complaint, just explaining how to obtain a "desktop view" all the time, everywhere. With the site set to desktop and the browser set to mobile view you get the super long skinny layout; which some do not like. To further complicate there is the additional setting, (under mobile), to "Disable Responsiveness", for extra ugliness. An additional factor is that SE detects your screen width, and does so incorrectly on high-DPI screens (Macs, iPhones, & new phones (even Android))... – Rob Jun 30 at 6:47
  • 1
    @Rob got it, thanks for the information! I wasn't aware if it. Quite complicated indeed. – Franck Dernoncourt Jul 3 at 18:23

You must log in to answer this question.

Browse other questions tagged .