I've noticed this twice in the last ~2 weeks or so. The "post your question" button can remain disabled for some reason even when your question is shown as "ready to publish". I.e., you've gotten to the "review" page after the initial edit.

If I remember correctly, one case was on Stack Overflow, and the other was on Retrocomputing.

I'm not sure what exact scenario leads up to this. I haven't paid attention to the button until the last step when I'm ready to click it.

The workaround has been to reload the page. (I copied my content for safe-keeping first.) This works, and the button then shows up as active. Afterwards, however, on both occasions, it forced me through the "are you a human" verification.

Update - this question itself did not exhibit this, nor did it do the CAPTCHA.

Update - I'm using Chrome on Windows and am not sure what version it was when this happened.

  • I used to have the same problem on StackOverflow, but nowhere else.
    – Ollie
    Jul 13, 2020 at 18:09
  • @Ollie I believe I remember your question about it. Wasn't that closed as no longer reproducible? Jul 13, 2020 at 20:52
  • @πάνταῥεῖ, I don't think I did post a question about that. And do you mean "no longer reproducible" as in they fixed it?
    – Ollie
    Jul 13, 2020 at 21:07
  • @Ollie Well, I remember there was a question (not necessarily asked by you). It wasn't really fixed, but the OP couldn't reproduce that behavior IIRC. Jul 13, 2020 at 21:56
  • Could it be that you posted a question less than an hour before you tried to post the next?
    – Red
    Jul 17, 2020 at 19:29
  • @AnnZen that might be the case, but even if it was my rep on both sites excludes me from the too-often-question limitation and as well, there was no message to explain if that was the reason. Jul 17, 2020 at 19:30
  • 1
    Well, I believe your case happened to me before, and it turned out that I needed to wait, even though they showed the "Your Question is ready to Publish" message.
    – Red
    Jul 17, 2020 at 19:34
  • @AnnZen thanks, if it occurs again I'll make note of these details. Jul 17, 2020 at 19:35
  • 2
    I ran into this as well here: meta.stackexchange.com/questions/352741/…
    – JonH
    Aug 6, 2020 at 15:52
  • another incident: meta.stackoverflow.com/q/400157/578411
    – rene
    Aug 10, 2020 at 20:39
  • Can you include your browser, OS, userscripts, adblockers, virusscanners as well?
    – rene
    Aug 10, 2020 at 20:40
  • @rene sure, done. Aug 10, 2020 at 20:42
  • Symantec Endpoint Protection caused me tons of problems in the past, I got rid of it quickly. :/ Aug 10, 2020 at 22:59
  • @ShadowWizardWearingMask its a corporate PC, not my call to make. Somehow I doubt it caused this problem tho. Aug 11, 2020 at 0:07
  • @UuDdLrLrSs well, if it's messing with web pages to "protect" you, I won't be surprised at all. It might identify one of the JS files used as a "threat" and disable it. Aug 11, 2020 at 11:44

1 Answer 1


This is fixed.

tl;dr, this was happening when you entered the review step using the Enter key, due to a rogue competing submit listener.

I had the hardest time with this one, because I couldn't initially reproduce it and there were no obvious code changes that would have introduced this bug. Looking at all code changes from June 10 through July 14, I couldn't find anything that directly even remotely interacted with the submit button and generally speaking, there are only three places where we disable it:

  1. On Stack Overflow, we disable the button by default for Teams users until they confirm they're drafting a public question. This doesn't apply here as it's happening on non-Stack Overflow sites and for non-Teams users.

  2. When we first bind on-blur post validation (title too short, invalid tag, etc.), we temporarily disable visible submit buttons and bring them back after all the fields have been configured. This wasn't causing it, because (A) the button wasn't visible and (B) if something was happening that prevented it from being enabled, an exception would have prevented the page from getting to the state it was in.

  3. We disable the submit button while submitting the form, but this shouldn't have come into effect, because that submit listener isn't even bound until post validation is wired up in the review step.

I finally figured out that there's a fourth, really unintuitive place that disables the submit button and it gets wired up really early. The Markdown editor itself actually attaches a form submit handler with the sole functions being to disable the submit button and remove the "Are you sure you want to leave this page?" prompts. This fires in tandem with my fix for Question can be submitted without review by pressing Enter in the tags bar, which listens for form submit events (triggered by Enter) and sends users to the review step. Both fired, so we ended up with the page at the review step and the page thinking it had submitted a form.

Ideally, I would love to remove the submit listener as it doesn't really belong there or make it default to off, but that's a fairly big technical debt project in a widely used and often deeply nested component. So the editor submit handler now emits a "I'm about to submit" event, which the ask page cancels on Step 1.

  • 1
    Please keep this up! Both the awesome bug fixing skills, and the not-less-awesome reports. Aug 24, 2020 at 7:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .