23

Today, while using the Stack Exchange app on iOS 14.1, it prompted for permission to access devices on my local network.

"Stack Exchange" would like to find and connect to devices on your local network. This app will be able to discover and connect to devices on the networks you use.

What types of devices could it be trying to access?

  • 4
    There's no mobile app development ever for a long time, so there's nothing change from the app. Instead, what is the iOS version? – Meta Andrew T. Nov 3 at 16:34
  • This is iOS 14.1 – spuder Nov 3 at 16:36
  • 12
    It also still doesn't answer the question, which is certainly a valid one. iOS 14 just exposes the fact that the app was already doing this, since nothing has changed recently. – zcoop98 Nov 3 at 17:38
  • 5
    What were you doing in the app prior to it asking permission? In my experience, if the app itself doesn't try to get permission to access something then iOS doesn't request permission until the app actually needs it. It was probably something you did that prompted the request and that might imply what devices it wants to connect to. – BSMP Nov 3 at 19:23
  • @BSMP And what feature of this website do you think would warrant such a permission request? – Asteroids With Wings Nov 3 at 20:07
  • 6
    @AsteroidsWithWings Why are you directing that question to me specifically? – BSMP Nov 3 at 20:08
  • 3
    @BSMP Why not? You suggested the OP "did something to prompt the request". That's fine, and possibly true, but now I'm wondering whether you can think of anything that relates to the functionality of this site which would result in such a prompt and actually be justified in doing so. – Asteroids With Wings Nov 3 at 20:11
  • 1
    ...and actually be justified... @AsteroidsWithWings I did not say or imply the permissions request was justified. – BSMP Nov 3 at 20:12
  • @BSMP And I didn't claim that you did! I'm just asking a simple, straightforward question. What's the problem? – Asteroids With Wings Nov 3 at 20:16
  • 3
    We need iOS dev experts or even SE staff here... this is a new notice since iOS 14 as explained in this SO question and Apple Developer community forum – Meta Andrew T. Nov 3 at 20:39
  • 4
    Really wild shot here (from someone who has zero knowledge) - it is bundled with some library that do privacy-policy-described-stuff which triggers request for the permission – Kos Nov 3 at 21:56
  • 3
    This thread seems to suggest that this can happen as a result of something as simple as querying a DNS server on the same network, as a new privacy feature of iOS 14 developer.apple.com/forums/thread/654243 – Stephen Nov 3 at 22:18
  • @Stephen is most likely correct, and it's something with the way the app use the device connection. Didn't dig deep enough to verify for sure though. :) – Shadow 10 Years Wizard Nov 4 at 6:22
13

From what I understand, this permission is used for streaming stuff to network devices and for smart home apps to work.

The Stack Exchange app should do neither of those things and not need this permission.

Go to settings, search for Stack Exchange, and turn this permission off. You don’t need it (and if for some bizarre reason I’m wrong and you did you could do the same to turn it back on).

When I updated to iOS 14, I wasn’t prompted for this and the app continued to work. I did eventually get the pop up but what triggered it was probably the fact that my internet connection was having trouble: no other apps that needed internet worked, and my computer was also unable to load anything. I denied the permission and when my internet came back, everything was fine. (I’ve seen this happen in iOS 14 with other internet connected apps before and I denied it with no ill effects, well before it happened in the SE app.)

As a result, I don’t think that this was malicious or even suspicious but rather something that was done in a futile attempt to have the app try to recover from internet problems.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .