When I try to use a Google account to authenticate to a StackExchange account, something strange happens -- On clicking the "Log in with Google" button with Google unauthenticated, the sign in to google completes fine but instead of getting redirected to the page before login, this appears on the screen and I can't login. Refreshing the page doesn't change it either.

Login fail

The message reads:

Request lacked state, may have been forged

But with Google already authenticated before clicking the Log In button, login to SE works as expected.

  • 1
    On a now deleted question a comment from the OP said: Turns out the anti tracker provided by my antivirus was causing the error. – rene Nov 9 '20 at 16:28
  • 1
    Yes turns out my adblocker is causing this. Thanks @rene – mugoh Nov 9 '20 at 16:42
  • 2
    Would you mind writing a self-answer describing which ad blocker you used and how or what you disabled? – rene Nov 9 '20 at 16:48
  • Sure, I'll try to rule out if a particular feature of the adblock was causing this and describe it in an answer – mugoh Nov 10 '20 at 6:53
  • So I happened to be certain that the ad blocker was the cause when I gave the comment because disabling it solved the issue. I guessed this could be it because it has an anti-tracker - a possible cause mentioned in rene's comment (first). This was on Chromium browser (v84.0.4147.105), the ad blocker being Ad Block Plus. However, I can't reproduce this fix on a different browser (Firefox v80.0 for Ubuntu). I have tried disabling all content-filters and ad blockers, including all browser extensions but in this case, the error persists. – mugoh Nov 10 '20 at 16:41

Removing the BitDefender Anti-Tracker Chrome Plugin fixed the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .