8

I usually log in on https://stackoverflow.com, after I do a full browser reset or cookie cleaning.

After this, I noticed I am not automatically logged in on https://stackexchange.com. So I usually log in a second time on https://stackexchange.com.

But then, for other sites:

  • meta.SE
  • SuperUser
  • AskUbuntu
  • ServerFault
  • etc.

I have to re-log-in on each of them!

There is no option like "Log in with your already-logged-in SE account":

enter image description here

As far as I remember, in the past, I used to log in on SO only, and then I was automatically in on the other websites.

How to enable this again?

It's very unconvenient to have to enter the username/password for every website.


Note : third party cookies are disabled in my browser Chrome. But I whitelisted these:

enter image description here

and the problem is still there.

Edit:

enter image description here

15
  • 2
    Do you allow third party cookies in your browser? If not, allow/whitelist the SE domains.
    – rene
    Commented Nov 17, 2020 at 13:32
  • Does this answer your question? Is it possible to sign in to all Stack Exchange sites without cookies?
    – Luuklag
    Commented Nov 17, 2020 at 13:35
  • 2
    @Luuklag No, I don't delete cookies on every browser exit. It's a different issue.
    – Basj
    Commented Nov 17, 2020 at 13:39
  • 2
    @rene True, I disallowed third party cookies in Chrome! That might be the reason. How to whitelist them? Should I whitelist also all domain specific websites: superuser.com, serverfault.com, etc. If so, would be interesting to have a detailed answer.
    – Basj
    Commented Nov 17, 2020 at 13:40
  • @rene I tried with "block third party cookies" still enabled, but whitelist (including 3rd party cookies) for stackexchange.com, serverfault.com. But still when arriving on serverfault.com I am logged out...
    – Basj
    Commented Nov 17, 2020 at 13:43
  • Did you re-authenticate once?
    – rene
    Commented Nov 17, 2020 at 13:44
  • @rene Please look at the edited question, I added a screenshot at the end.
    – Basj
    Commented Nov 17, 2020 at 13:44
  • Also see: meta.stackexchange.com/questions/56161/…
    – Luuklag
    Commented Nov 17, 2020 at 13:45
  • @rene Yes, I just did. I cleaned all cookies, and re-authentificated once again on SE.com Then going on serverfault.com shows the same problem.
    – Basj
    Commented Nov 17, 2020 at 13:46
  • Hmm, strange. Based on the details in my answer here: meta.stackexchange.com/a/312956/158100 I would expect that now to work.
    – rene
    Commented Nov 17, 2020 at 13:47
  • Can you also whitelist [*.]stackauth.com?
    – rene
    Commented Nov 17, 2020 at 13:51
  • If you clean cookies and then re-authenticate please use stackoverflow.com and then visit serverfault.com. StackExchange.com is a bit weird and might not cooperate as you would expect.
    – rene
    Commented Nov 17, 2020 at 13:53
  • I retried all of this: i.sstatic.net/DgtB0.png (see edited question), but it still fails. Should [*.] be included in the pattern?
    – Basj
    Commented Nov 17, 2020 at 13:55
  • @Basj Hmm, maybe that pattern is not correct in hindsight. If you open a dev console, can you see the calls being made to the other domains and are there cookies returned in their response headers?
    – rene
    Commented Nov 17, 2020 at 14:02
  • Hi @Basj, were you able to solve this issue in the past years ?
    – Atralb
    Commented Sep 16, 2023 at 23:50

1 Answer 1

2

You may need to allow all cross-site cookies and third-party cookies. I have also tried setting the tracking prevention (in Edge/Firefox/Chrome) to balanced and disabled any blocking extensions. It should work after a browser reload (that is, closing the browser and then opening it again with the same windows.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .