15

As a Room Owner of a room on chat, I can see an option for "moderator" if I go to adjust the access settings for a user in that room:

Access for Mithical: no special access, read access, write access, moderator, owner

However, it doesn't appear to actually do anything. If I try to use this option on anybody, I get the same error every time (with the URL https://chat.meta.stackexchange.com/rooms/info/89/tavern-on-the-meta?tab=access&error=7):

The user already has an explicit access setting for this room.

This happens if the user is: A staff member, a moderator, an owner, has write access, or no access (yes, I tried on all of them).

So: What purpose does this option serve, and why doesn't it do anything for me?

6
  • 2
    Trying to get privileges back through the backdoor?
    – rene
    Dec 5 '20 at 17:31
  • I tried giving you explicit mod access to the Den but no luck there either, same error although you don't have any explicit access to that room
    – rene
    Dec 5 '20 at 17:37
  • 7
    It's part of the new TL moderation tooling we're testing and will be announcing next week. I wasn't expecting it to be visible since only CMs should be able to use that option.
    – Catija StaffMod
    Dec 5 '20 at 17:38
  • 5
    ... not quite sure why this is being downvoted, though. I think it's likely a bug, in the long run.
    – Catija StaffMod
    Dec 5 '20 at 17:39
  • @Catija probably downvoted by users like me that are utterly disappointed that this option can't be used to instantly get mod powers in chat. ...
    – rene
    Dec 5 '20 at 17:41
  • 3
    Hahaha. @rene That's not Mithical's fault. ;) I'll have the write-up early next week probably.
    – Catija StaffMod
    Dec 5 '20 at 17:43
7

This is a bug and it has been fixed.

The problem is related to a new user type being added to a new type of room (which Catija will be writing up). On the backend, the moderator role is restricted to moderators and to a certain room type. When I wrote the validation code, I reused the UserAccessChangeResult.ExplicitAccessCannotBeChangedToRequest error code, which certainly sounds correct but has an error message that is completely unhelpful in this context.

But... you still shouldn't see this option. Like 5 users on the whole network could actually use it, and they'll all be employees in practice. The problem here is that the JavaScript isn't aware of when to show it or when not to. Since it's just employees who will see it and there's already another mechanism for assigning roles, I'm just updating the code to (almost) never show the option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .