5

It looks like links to questions within quotes are being rendered with the question title in the edit mode preview, but as a URL in normal viewing.


Given the following question Markdown:

Testing some link formatting:

https://meta.stackexchange.com/questions/70710/what-are-tag-synonyms-and-merged-tags-how-do-they-work

"https://meta.stackexchange.com/questions/70710/what-are-tag-synonyms-and-merged-tags-how-do-they-work"

The following images show the difference in rendering between edit mode & view mode:

Question view:

enter image description here

Edit preview:

enter image description here

Current live rendering:

(Actual live rendering, not an image. This can be used to view the current behavior, including the discrepancy.)

Testing some link formatting:

What are tag synonyms and merged tags? How do they work?

"https://meta.stackexchange.com/questions/70710/what-are-tag-synonyms-and-merged-tags-how-do-they-work"


There are other past issues about link rendering discrepancies, but none of them seem to be quite this issue:

3
  • The preview and the actual posts use different renderers. It's a known fact the the server renderer only recognises URL's when they are enclosed in spaces. – Luuklag Dec 7 '20 at 19:43
  • 2
    It appears that I was mistaken. Double quotes at the start of the link break the URL, not at the end. You can see in your sandbox answer, I tested there. – Luuklag Dec 7 '20 at 19:55
  • 1
    The referenced sandbox answer, for those playing along at home: meta.stackexchange.com/questions/3122/formatting-sandbox/… – M. Justin Dec 7 '20 at 20:09

You must log in to answer this question.

Browse other questions tagged .