This suggested edit, while a useful one, only edits a single character in the answer. How did it manage to bypass the minimum 'edit size' of 6 characters?

enter image description here

When I try to change just the 'B' to a 'C' as an anonymous user, I'm unable to:

enter image description here

  • 3
    Now, it is easy to workaround this: add 10 characters, plus your one-character change, then remove these 10 characters in the next edit for the same post. – that doesn't work anymore. Just tried ...
    – Glorfindel Mod
    Commented Jan 22, 2021 at 15:00
  • 1
    Does it have something to do with the fact that the whole paragraph is highlighted in the diff, rather than just the single changed character? Or does it always do that?
    – zcoop98
    Commented Jan 22, 2021 at 16:19
  • It looks like you did that anonymously, while the other person did it as a registered user; so they had grace while you were two different users. --- On another point: Algorithm explanation: meta.stackexchange.com/a/128705/282094 (found while scrutinizing this false lead that was unearthed from this seemingly duplicate but not Q&A).
    – Rob
    Commented Jan 22, 2021 at 16:39
  • 1
    Suggested edits that modify the question title aren't subject to a 6-character requirement for editing the body. That said, the edit is to an answer, so that's not the thing at play here. Commented Jan 22, 2021 at 20:10

1 Answer 1


I've been able to shed some light on this by comparing the Markdown of the two revisions with this SEDE query. The old revision has Unix line endings (just \n) while the new one has Windows line endings (\r\n):

enter image description here

It's understandable that the diff doesn't show any difference, but I always thought whitespace was ignored when it came to the character limit. In this particular case, it isn't, and I was able to submit a suggested edit appearing to change nothing here.

(Note: an earlier version of the query only worked if the suggested edit was actually accepted; the new one is also easier since it only needs the review task ID.)

  • Too bad you can't perform a concurrent edit to auto-reject it as an edit conflict anymore. Commented Aug 22, 2021 at 9:52
  • @SonictheSaveUkraine-hog right. I have a workaround for that; would you mind pointing me where I can post that? I've tried searching for posts mentioning that behaviour but failed ...
    – Glorfindel Mod
    Commented Jun 26, 2022 at 17:08
  • This question and my answer to it. Commented Jun 29, 2022 at 6:24
  • @SonictheSaveUkraine-hog thanks, posted
    – Glorfindel Mod
    Commented Jun 29, 2022 at 6:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .