13

I noticed that when reviewing the review queues the "Submit" button is not being enable to finish the review. I checked on U&L, AU, SO, SU but none working (in all review queues same issue).

Note that I also selected/do some "Action"s but still remain Disabled

I'm on PC and on Edge browser v44.19041, before I had no issue until I noticed just start about from 30 minutes ago. I checked on another PC and on Edge browser v88 no such this issue.

Browser Console doesn't output anything. On Phone using Chrome Browser no issue.

6
  • clearing cache also didn't help; JavaScript was enabled; after all I have upgraded from v44 to v88 and problem resolved Commented Feb 24, 2021 at 13:34
  • 1
    I notice the same behavior a couple days ago, it was due to using an unsupported browser, I logged into a different browser and it worked normally. Edge 44 is EdgeHTML, which isn't supported by Microsoft, if I am not mistaken SE only supports supported browsers.
    – Ramhound
    Commented Feb 24, 2021 at 15:07
  • @Ramhound is that documented somewhere? because based on this meta post meta.stackexchange.com/a/71208/703623 they mentioned that is the supported browser version "Both New Edge (Chromium-based) and Legacy Edge (EdgeHTML-based) are supported." Commented Feb 24, 2021 at 17:02
  • 1
    Edge 44 went of of support in 2021. That particular list of browsers were last updated in 2020. Specifically 4 months ago, and 3 months, before Edge 44 reached End of Support by Microsoft. it could be a bug, but Legacy Edge in April, will removed on the majority of Windows 10 systems
    – Ramhound
    Commented Feb 24, 2021 at 18:13
  • @Ramhound That's true. I might mention that at the time the browser matrix was last updated, there were no plans for Microsoft to phase out support for Edge Legacy, and it was thought that they would continue to maintain it alongside the Chromium version. Commented Feb 25, 2021 at 3:09
  • 1
    The "Submit" button remains inactive here on an old box running Firefox 48.0.2, (yes I know it's old) - Farewell review queue.
    – RobC
    Commented Feb 25, 2021 at 16:30

1 Answer 1

7

Whew - got it figured out! What an adventure in browser compatibility research.

The issue here was the input event. It's supported across all modern browsers, but on older Microsoft Edge versions, it's not supported for dropdowns or radio buttons. We were attempting to enable the submit button on an input event. I've updated that to enable submit on both an input and a change event, and now it works properly.

We'll have the fix merged in tomorrow, most likely. Thanks for bringing it up, and sorry it took so long for us to get to it!

3
  • So you are now optimizing for unsupported browsers?
    – Luuklag
    Commented Apr 6, 2021 at 8:37
  • I don't think optimizing is the right word. More like, this is an easy fix, and if it makes the review queue usable for more folks who'd like to use it, then we'd like to fix it if we can. If the fix had been very time or labor intensive, we may not have been able to.
    – kristinalustig StaffMod
    Commented Apr 6, 2021 at 11:26
  • @kristinalustig - thank you for fixing this, the "Submit" button is now being correctly enabled. However, I believe a similar fix is also required for the "Reject edit" button. Steps to reproduce the associated issue: 1) Select "Reject" and click the "Submit" button. 2) In the subsequent "Why are you rejecting this edit?" overlay/dialog choose an option from the list, e.g. "No Improvement". 3) Note: the "Reject edit" button remains disabled.
    – RobC
    Commented Apr 19, 2021 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .