31

Lately I've been seeing this cookie popup that blocks a lot of the screen. When I try to do the "manage cookies" thing, all it shows me are several categories, with a green oval containing a black circle to the right of each. Clicking on that oval makes it disappear. Clicking on the same spot again makes it reappear. But I see no indication as to which state is off or on.

So how can I make this popup go away, never to bother me again? Or failing that, could you at least provide some indication as to what those buttons do? Like maybe simple text saying "Off" or "On"?

19
  • 2
  • 21
    No matter how many times I accept the cookies, the pop-up keeps coming. On almost all sites that I visit regularly. It's getting irritating. Mar 30 at 19:23
  • @WrichikBasu then don't keep deleting your cookies ;)
    – Luuklag
    Mar 31 at 7:49
  • 2
    @Luuklag I don't manually delete any cookies. Probably chrome deletes it. I will have to check it. Mar 31 at 8:09
  • 1
    For any devs wondering about why this is status reviewed - specifically there seem to be issues with safari as per rene's answer, and this... might make things difficult for a significant part of the SO and SE userbase.
    – Journeyman Geek Mod
    Apr 4 at 12:31
  • it's huge, especially annoying when you're on a live CD browser on a small screen
    – CervEd
    Apr 16 at 7:07
  • 1
    @jamesqf I've reproduced this issue running Firefox and the extension you've got installed. Ad blocker bugs aside, this use case is unsupported, so I'm setting this to status-declined. With all the re-coloring plugins out there, we'll never be able to support those. Did you know we've got our own official dark mode? It's available to users with an account. Check out your preferences and try it out?
    – Aaron Shekey StaffMod
    Apr 19 at 17:48
  • 1
    @AaronShekey in defense of the OP , dark mode is only available on SO sites but not on World Building which seems to be their main site.
    – rene
    Apr 19 at 18:05
  • 2
    @rene fair enough! Someday network sites will get full dark mode.
    – Aaron Shekey StaffMod
    Apr 19 at 18:11
  • 1
    @AaronShekey I have no doubt you'll come to the dark-side eventually ;)
    – rene
    Apr 19 at 18:13
  • @AaronShekey is there a more precise timeframe then next 6-8 decades, for network wide darkmode?
    – Luuklag
    Apr 19 at 18:31
  • 2
    @Luuklag No timeline since it'll take me about 6-8 decades to do all the theming if it gets prioritized.
    – Aaron Shekey StaffMod
    Apr 19 at 19:07
  • @Aaron Shekey: Thanks for trying. I'll just point out, though, that an official "dark mode" for SE only would not seem to do much for me, since I want EVERYTHING I view to appear this way. (FTM, wouldn't using SE's mode in combination with a plugin just swap everything back to the original?) WRT the original problem, would not simple text saying "off" and "on" work regardless of mode? Even in the "light mode" screenshots below, there's no real indication of what having the little circle on one side or the other is supposed to mean.
    – jamesqf
    Apr 20 at 3:33
  • Tried the native SE dark mode, went back to Dark Reader. The two main issues is getting the white screen if you happen to not be logged in, and that the native mode just isn't dark enough.
    – Roger Dahl
    May 3 at 20:33
  • @jamesqf Use the global-color-inversion of your OS. It's available in some form in in Windows, Ubuntu, MacOS, Android, and iOS. Playing whack-a-mole with trying to get every app and site you use to activate a dark mode is a fool's game, and they always mess it up somehow anyway.
    – tsbertalan
    Jun 3 at 14:27
21

Here’s a uBlock filter to disable it:

stackexchange.com##.js-consent-banner
superuser.com##.js-consent-banner
stackoverflow.com##.js-consent-banner
mathoverflow.net##.js-consent-banner
serverfault.com##.js-consent-banner
askubuntu.com##.js-consent-banner
stackapps.com##.js-consent-banner

If you don’t read the message, you decline consent by default.

8
  • 1
    Thanks. Now if I knew (or had known, prior to doing a search :-)) what a uBlock filter was, and how to use it, I'd be set. But I am far from being an expert in javascript (I assume that's what the "js-" means), or really anything to do with web programming.
    – jamesqf
    Mar 31 at 16:50
  • @jamesqf You don’t need to know JavaScript; it’s enough to just copy-paste this block of text into your list of custom filters. (Also, use uBlock Origin, not plain uBlock; the latter has been compromised.) Mar 31 at 17:18
  • @jamesqf uBlock Origin is an ad-blocking browser extension that can also be used to block certain HTML elements from being displayed, which is what this answer makes use of.
    – 41686d6564
    Mar 31 at 17:56
  • @user3840170 I've added the uBlock filter now, but how do I enter those lines? I got the popup removed by clicking "enter select element mode" then clicked the ugly and annoying cookie request, then clicked "create" which created that filter, but I'd like to be able to add them all at once with the lines you gave us here. Also, do you know a solution for android phones? Apr 4 at 19:44
  • Thanks for reporting. This is part of a series of connected bugs that the team is looking into.
    – Rosie StaffMod
    Apr 6 at 15:57
  • @user1271772 (0) Open uBlock settings, paste this into your list of custom filters (1) Firefox for Android. Apr 6 at 16:03
  • @user3840170 I installed firefox just for this, but the cookie popup still shows up. Do I also need ublock on top of firefox, on my android device? Apr 22 at 9:49
  • I got it working in firefox on Android after installing ublock. May 24 at 10:23
8

There is a reported bug cookielaw.org keeps popping up that for iPad / iPhone / Mac (Safari) users this popup always returns on the next page load, no matter what you try. That needs to be fixed first before this answer makes Safari users happy.

You can make the popup go away by clicking Accept all cookies

enter image description here

That will store your choice on your browser.

If you prefer to tune which cookies you allow click Customize settings and shows you this dialog:

enter image description here

In the dialog a setting is ON when the white circle is at the right side of the oval. The oval becomes green. It is OFF when the white circle is at the left side of the oval. The background of the oval becomes grey-ish.

Click the question mark for each category for information on what those cookies are used for. enter image description here

Click Confirm my choices to generate the two cookies named:

  • OptanonConsent
  • OptanonAlertBoxClosed

See this answer if you feel for setting these cookies by hand

Those cookies have an expiration date of a year ahead. So if you never touch that dialog again you might have to re-confirm your settings once a year.

Check the whole cookie list here

Once you've set your preferences and later want to revisit or amend your choices, click the Cookie Settings link found in the footer:

The cookie settings link is found in the second column named Company, second to last link

15
  • Excellent use of freehand circles. Worthy of upvoting!
    – Luuklag
    Mar 30 at 17:52
  • 12
    ... Unless your browser does not store cookies. Or if you block some JavaScript. In that case you are forever cursed with that popup.
    – Quasímodo
    Mar 30 at 18:26
  • 4
    @Quasímodo the other answer nicely addresses that scenario. There is no need for me to repeat that excellent answer here.
    – rene
    Mar 30 at 18:31
  • 1
    This is incorrect. Your browser is apparently set to show black/colored text on a white/colored background. Mine is set to show white/colored text on a black background, which is much easier on my eyes. As I said, clicking on the ovals simply causes them to disappear. Further, as a question of basic user interface design, how are people supposed to know which position of the circle in the oval represents off, and which on?
    – jamesqf
    Mar 31 at 16:43
  • @jamesqf I'm sorry to hear that. It wasn't clear from your question that you used / applied a different color scheme. Maybe a screenshot can help there and then switch the tags to bug. I assumed you were asking about the functionality the dialog offered and needed assistance in correctly using it.
    – rene
    Mar 31 at 16:55
  • @jamesqf I assume you're using a colorscheme that is used by your browser or operating system. Do you mind sharing the browser brand / version and your specific setup so we know what we have to solve?
    – rene
    Mar 31 at 17:09
  • When I click the Customize settings button on the popup, nothing happens :( Apr 3 at 4:14
  • @KyleVassella are you blocking javascript, for example those from cookielaw.org? Your browser developer console should reveal that.
    – rene
    Apr 3 at 7:20
  • 2
    I can't make it go away on my iPad. Every refresh, every new page, it reappears. I have not changed any settings and I am not about to just for Stack Overflow. Fix it.
    – user207421
    Apr 4 at 3:59
  • @user207421 yes, that needs fixing and there is a bug report for: meta.stackexchange.com/questions/362091/… . Just to help diagnose: I assume you're using the Safari browser? Or asked differently: you didn't install or use a different browser on your iPad? If you have installed a second browser (I believe Chrome comes in an native iPad version) can you try reproduce there? You don't need to login in, the consent dialog is shown to anonymous users as well.
    – rene
    Apr 4 at 6:29
  • This is happening regularly on my Windows browser too (Windows 10). I wonder if it's waiting for me to either get sick of it and click accept all (or accidentally click accept all). But I don't want to accept all cookies thank you very much! I agree with user207421--it would be nice if StackExchange would fix this rather than make users try to change their settings or do other stuff that we may not understand.
    – paw88789
    Apr 5 at 1:10
  • @rene: I'm using Firefox 60.0 running on OpenSUSE, using an extension called "Dark Background and Light Text", version 0.6.12.
    – jamesqf
    Apr 5 at 3:25
  • @jamesqf I installed that extension and the way it changes the colors is incompatible with how the Stacks Design CSS works. I fiddled a bit with the preferences of that extension but I couldn't find a setting that would resolve the issue. If you can't see the toggle, it means it is off. I doubt you will get a resolution for this problem from SE. Maybe the extension maintainer takes suggestions to add options to have some finer control over which elements needs to get their (background) colors overridden.
    – rene
    Apr 5 at 7:06
  • @rene: Thanks for looking. Do you know of some other extension that will do the same thing, and work with SE? I know very little about extensions and such, and would just like to get a display where I can see everything with a black background. I have noticed that there seem to be things that other people see that I don't.
    – jamesqf
    Apr 6 at 3:20
  • @jamesqf I've not looked into other extensions but if you search for dark mode here on Meta you'll find some suggestions. A recent one is found here meta.stackexchange.com/a/336626/158100. I didn't check if that particular one solves the specific issue you face.
    – rene
    Apr 6 at 5:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .