3

I've just come back from a weekend holiday and encountered a strange and rather annoying glitch.

If I try to edit a question - any question, anywhere on the network - the "Save Edits" button is permanently disabled, and does not get enabled no matter what I do. I can seem to edit questions here on Meta.SE, interestingly, but everywhere else on the network, I see this:

The button is flat and its color is washed out, indicating it is disabled.

(example from SciFi.SE)

I can edit answers perfectly fine; this is only happening on questions. Considering there are no other reports of this bug, it's either a) very recent, or b) only happening to me (I'm using Windows 10 and Google Chrome version 91.0.4472.77, the very latest version).

When I check the developer console, I see the following error, which may be related:

The HTTP request status code is 200, which means OK, but there was an error decoding the data.

Could this be looked into, please?

8
  • Strange! You just edited this question. No? Or does this only happen with questions that you aren't the author of?
    – 41686d6564
    Commented Jun 1, 2021 at 9:32
  • It seems I can edit questions here on Meta.SE, but only on Meta.SE. I just tried editing one of my questions on Writing.SE and the button was disabled.
    – F1Krazy
    Commented Jun 1, 2021 at 9:36
  • I can see a bunch of quite recent non-author question edits on the sites I’m active on. So the glitch must be rare. Commented Jun 1, 2021 at 10:44
  • First of all, disable any userscript or custom style sheet you have, even those you don't think are related. One of them might mess with the pages. If after disabling all scripts/style sheets it works, enable one by one to find the culprit. If not, next suspect is ad blocker. Sometimes they're too trigger happy any block stuff which aren't really ads, and required for the site to function. Commented Jun 1, 2021 at 12:39
  • 2
    @ShadowTheVaccinatedWizard I don't have any userscripts or custom style sheets. I tried disabling my ad blocker but the problem persists.
    – F1Krazy
    Commented Jun 1, 2021 at 12:54
  • 1
    Next debug step, open the developer console of your browser and check for client side errors. Do you see anything? Commented Jun 1, 2021 at 13:28
  • I can't repro. Are you still seeing this? I'm also using Windows 10/Chrome 91, and the button on SO and Unix isn't disabled for me.
    – Ollie
    Commented Jun 1, 2021 at 14:18
  • 1
    Yes, I'm still seeing this. @ShadowTheVaccinatedWizard I do indeed see a client-side error when I open the post editor; I'll add a screenshot of it to the question.
    – F1Krazy
    Commented Jun 1, 2021 at 14:28

1 Answer 1

7

As of five minutes ago, it seems this has been fixed - the issue no longer occurs, and the error message I was seeing in the developer console no longer appears.

enter image description here

(example from Movies.SE)

Would be nice to get some official word on what happened here, but in the meantime, no harm, no foul, I guess.

1
  • 1
    I don't believe anything was done on our end. There was likely just a glitch somewhere along the line on the way to your computer that was causing you to get a corrupted copy of the JS file.
    – animuson StaffMod
    Commented Jun 2, 2021 at 14:17

Not the answer you're looking for? Browse other questions tagged .