Empirically it seems that I just gained tag wiki edit suggestion privileges (ability to add a suggestion to the review queue, not to get my changes approved without peer review) in Stack Overflow when my reputation got over 500 points. However, this old answer suggests there is a completely different logic involved, but it doesn't seem to match my personal experience. As far as I can tell the current logic is not explained in the FAQ or on SO's own privileges help page, although there is a lot of content in both and I might have missed something.

I did see somewhere a note that anyone can suggest edits to the tag wikis, but I've misplaced where that was (somewhere within the linked FAQ pages, possibly?), and at least personally I couldn't suggest tag wiki edits in SO last week when my reputation was 495. I assume that this could be one of the many cases where SO does things a bit differently than most sites, but if so, is the limit in SO truly 500 reputation or some other milestone that I happened to hit over the weekend?

Edit: there was no 'Edit tag info' button at all when I tried on Friday, but now there is.


1 Answer 1


You do need to have an account to suggest edits to tag wikis (unlike regular Q&A posts which allow anonymous suggested edits), but there is no reputation level required. See the FAQ for more details.

Not seeing the 'Edit tag info' button could have several reasons:

  • You already have 5 suggested edits in the queue (20 on beta sites) - given your reputation history, this is the most likely cause.
  • There is already a pending edit; right now, you can try this example (I have a pending suggested edit there)

Other reasons for not being able to submit suggested edits (but not sure if they hide the Edit button) could be a full suggested edit queue. On Stack Overflow, it contains 464 items (out of a maximum of 500) while I'm writing this.

  • 1
    I've run into a full suggested edit queue many times, but usually it just gives me a popup warning when I click the edit button, or the save button if the queue has filled while I've been working on my edit. For the tag wiki I didn't even have the 'Edit tag info' button at all, just 'History' and 'Excerpt history'. Is the logic different for tag wikis? Commented Jun 7, 2021 at 9:40
  • Ah, I didn't know the button was missing. I know of two situations when that might happen; see the updated answer.
    – Glorfindel Mod
    Commented Jun 7, 2021 at 10:03
  • I see the button on the example tag page, and it lets me click it without warnings, although I didn't actually try to make and save any edits. Having had my edit queue full is certainly an option, though. Hadn't noticed any other edit buttons disappearing because of it, but I could have missed it. Commented Jun 7, 2021 at 10:10
  • 1
    I also saw the edit button on [entity-framework-4.1] but after I closed and reopened the page, the button disappeared and it doesn't seem to show up anymore. Something is glitching here. Or maybe I should blame caching.
    – 41686d6564
    Commented Jun 7, 2021 at 11:37
  • I tried several times with both Firefox and Chrome but the button is still there, and I'm fairly certain I had never before visited that particular tag's page. Weird. Commented Jun 7, 2021 at 12:21
  • 'Empty cache and hard reload' did the trick with Chrome, now the button is indeed gone. Interesting caching mechanism. Commented Jun 7, 2021 at 12:33

Not the answer you're looking for? Browse other questions tagged .