-8

After 'Browsing' an image, it does seem to upload, and the thumbnail appears (inside the Imgur box), but then 'Adding' returns to the text being edited without the image link being inserted. No markup code is generated at all.

Or am I doing something wrong?

The browser is Firefox 89.0, OS: Slackware-current64 (about three weeks old), no visible errors. As I reported, the image does upload, as a thumbnail appears in the upload dialog.

Nice one.

  • I just tried to insert the image here (on Meta) and it did succeed.
  • I still had the tag open on Stack Overflow, so I tried again there. No luck...
  • I reloaded the page on Stack Overflow, and tried again, and yes, it did function properly now. So, ignorant me suspects there's either some way image uploading can get blocked during normal use, or the problem was solved in the meantime. (Note that I did several reloads when I originally detected the issue)

Both protocols compared

10
  • 4
    Which site are you trying this on? Which browser are you using? Does it work with extensions disabled? Use the browser console (dev tools) (hit F12) and read any errors. The dev tools provide a Network tab. Do you see a failed or blocked request there? – Sebastian Simon Jun 27 at 23:20
  • 1
    “the image does upload, as a thumbnail appears in the upload dialog” — That’s not the actual upload; that’s a temporary Blob URL from the provided file. Right-click and inspect the image. It’ll have a src starting with blob:, not an actual Imgur URL. – Sebastian Simon Jun 28 at 1:11
  • Ok... Looked at the network comm while clicking 'Add image' and there are no error message, as far as I can see. I haven't found how I can switch to the Alpha version to compare. I have previously published a few images without issue. I did update FF a couple of weeks ago. – jcoppens Jun 28 at 1:35
  • The alpha editor is announced here: Opt-in alpha test for a new Stacks editor. – Sebastian Simon Jun 28 at 1:43
  • Do you have one or more of those? 1) Userscripts 2) Browser extensions 3) Ad blockers – Shadow Wizard Wearing Mask V2 Jun 28 at 7:11
  • 1
    Why is this so downvoted? Aren't veteran users supposed to help those who have a problem with the interface? – Mari-Lou A Jun 28 at 7:27
  • @Mari-LouA probably because the question lack(ed/s) details. – Luuklag Jun 28 at 7:30
  • @Luuklag I see some details: Browser: FF, OS, which was added 10 hours previously, yet the post still attracted further DVs. Were it me, I wouldn't know what other information to add. – Mari-Lou A Jun 28 at 11:37
  • The picture is for a signal from an IR remote control (e.g., for a television). – P.Mort. - forgot Clay Shirky_q Jul 1 at 15:58
  • Thus, it is likely for Electrical Engineering. – P.Mort. - forgot Clay Shirky_q Jul 1 at 16:18
2

Works for me in both classic and Alpha editors

Animated Gif of image upload in Alpha editor

Alpha editor - this has no preview option

Animated Gif of image upload in classic editor

Classic editor, from Super User

1
  • Thanks for the animation. Just to be clear: That's exactly what I did, only the Markup code did not appear after clicking 'Add image'. Anyway, it works now, after today's reload of the page (see comments added in original post). – jcoppens Jun 28 at 21:12

Not the answer you're looking for? Browse other questions tagged .