15

I have my main account for this site that signs in with Google. However for work, I created a separate Google account for various purposes (working with a VDI, it's annoying having trivial things persist across sessions, but that's neither here nor there).

When signing in, I accidentally clicked too quick, and signed in with the 'work' email, beginning to create an account. I tried pressing cancel, but any time I go to sign in with Google, it forces me to finish creating an account. I tried deleting cookies and temp files on my end, but no dice. I figured it was server-side but I wanted to be thorough, anyway.

So I created the account, and promptly went to my settings to delete the account. Unfortunately, while that succeeded, trying to sign in with Google again causes me to get the same "You are about to create an account" with this email. I don't want that. I want my original account. How can I eliminate this incorrect email from Stack Exchange and go back to my normal account? I thought about merging accounts but I'd rather not play a waiting game.

EDIT: Now, if I log out, and click "Sign in with Google", it automatically logs me into this account. Grrr...

EDIT 2: So I just added a login using the work email, and DELETED the Google sign-in. And then when trying to sign in with Google.... It goes back to the "Confirm your new account" page for the work email. Yeah, this is annoying. Real annoying.

8
  • 4
    Might possibly have something to do with your two accounts being automatically merged, but we'll have to get a staff member to confirm. Sep 7, 2021 at 20:00
  • 1
    I really hope they didn't merge. I didn't see any questions on the profile originally and I've asked a good many questions on the original account (And quite a few closed, lol), so I would hate to lose all of that if deleting the account the first time killed off that one, too...
    – user1066956
    Sep 7, 2021 at 20:03
  • So I just added a login using the work email, and DELETED the google sign-in. And then when trying to sign in with Google.... It goes back to the "Confirm your new account" page for the work email. Yeah, this is annoying.
    – user1066956
    Sep 7, 2021 at 20:09
  • @Anonymous then it didn't merge.
    – user1066956
    Sep 7, 2021 at 20:13
  • What is "VDI"? Virtual Desktop Infrastructure? Or desktop virtualization in general? Or something else? Sep 7, 2021 at 20:25
  • @P.Mort.-forgotClayShirky_q Yes, exactly what it means.
    – user1066956
    Sep 7, 2021 at 20:37
  • 2
    Have you tried signing out of your work email at Google? Or signing into a second account there? If you are only signed into one account that is authorized to Stack Overflow, Google will just immediately redirect you back to the site.
    – animuson StaffMod
    Sep 8, 2021 at 5:37
  • @animuson This seemed to work for me, as well. Same as going incognito, though as a more permanent fix. As for why when I'm signed in to the browser it latches onto the site, I don't know; I don't see anything in Chrome's settings that forces this (when I literally had the option to select, before), but that seems to be that. Thank you again!
    – user1066956
    Sep 8, 2021 at 13:31

3 Answers 3

-2

Method 1- One thing which you want try is to go in incognito mode using Ctrl+Shift+N. Then open say meta.stackexchange.com and write your email id and click on forget password and go to your gmail and either in Inbox and Spam click on the mail and write the new password. Login (without google) by typing email id and password in that space

enter image description here

and then click on Save Password. This way you can login without using google. Even I guess this way can also work in normal chrome.

Method 2- Always go in Incognito and then login into stackexchange using google. Put your SE email google email and password. This will work for sure.

1
  • 2
    It's a solution, and it's the only one given as an answer so far. I tested this just now, and funny enough, I was able to go to "Sign in with Google", and CHOOSE an email address, so it's something to do with the browser. In any case, I've since adjusted the login credentials of my original account, and shall promptly be deleting this one. Thank you, again!
    – user1066956
    Sep 8, 2021 at 13:29
13

Go to https://accounts.google.com, and if necessary switch to the account that it keeps trying to log you in to stack overflow sites as.

On the left hand side, choose "Security".

Scroll down to the section "Signing into other sites" and click "Signing in with Google"

Click on the entry for Stack Overflow, then press the "Remove access" button.

After doing this it let me log out of stack overflow, and then when I went to log back in I was allowed to choose different credentials.

0
-1

In a comment, animuson ♦️ wrote:

Have you tried signing out of your work email at Google? Or signing into a second account there? If you are only signed into one account that is authorized to Stack Overflow, Google will just immediately redirect you back to the site.

This worked for the OP as mentioned in their response to animuson's comment.

You must log in to answer this question.