5

I initially thought this affected MSE only, but now I started to face the same issue on other SE sites.

I've encountered/reproduced only on Stack Exchange on Firefox for Win 10.


Place cursor at the start of a paragraph:

enter image description here

Press Enter twice, and try to move cursor up using the key:

enter image description here

Huge delay is faced when moving the cursor up one or two lines.

I asked in chat a couple of days ago on how best to report it, so if there's any data the team here needs, let me know.

Note: I can repro most of the time, and it only affects (as far as I've encountered) jumping to blank lines.


Update: Based on two comments, the issue affects Firefox in general, though as demonstrated in another comment, it doesn't affect Wikipedia; for the time being I've rolled back the addition of the tag until the issue becomes more clear.

24
  • This is just a visual lag. The cursor actually moves instantly. I initially assumed this was just a Firefox bug… Sep 15 at 21:23
  • 3
    I can confirm this problem. Firefox version 92.0 on Ubuntu MATE 20.04 (Focal Fossa) (but with Cinnamon), with a spell checker. The problem started a few days ago. I thought it was the spell checker as it can be quite CPU intensive on some (long?) pages, but apparently not. Sep 15 at 21:25
  • 3
    And: 1) Using NoScript, only allowing the necessary domains to get JavaScript code from. 2) An unspeakable number of tabs 3) Rotating rust (yes, I know) 4) On all sites I have tried, but not on all arrow up/down key uses, approx. every 4th (or it may be time based, like slow every 5 seconds), but it is somewhat intermittent. 5) Total CPU load is light, less than 5%, and the CPU load doesn't shoot up when it slows down. 6) Not out of physical memory (though Firefox is a beast) 7) 4G/LTE connection Sep 15 at 21:56
  • Can you check if it happens in Firefox in any textarea outside of SE? Sep 15 at 21:59
  • 2
    @Cave Johnson: There aren't any problems with the main editing window for the Wikipedia article 4G (about 300 lines and 55 KB). Sep 15 at 22:03
  • 1
    It is especially pronounced when moving to an empty line (with up/down arrow keys). The delay can be up to about 2 seconds. Sample post to try it on. Sep 15 at 22:10
  • 1
    Re "one blank line to another blank line.": It also happens when going from a non-empty line to an empty line. Sep 15 at 22:21
  • @P.Mort.-forgotClayShirky_q: yes that's a better description, I've updated, thanks
    – ymb1
    Sep 15 at 22:34
  • 1
    The problem persists (2021-09-19). I think this should be retagged as a bug (instead of support). Sep 19 at 9:51
  • 2
    @P.Mort: Done. And yes persists here as well.
    – ymb1
    Sep 19 at 14:38
  • 1
    @P.Mort.-forgotClayShirky_q deciding factor for me was simply turning on Violentmonkey. Almost no tabs, PC running smoothly otherwise. Also on a 3G. All things considered this hadn't happened before using the same setup and there haven't been any OS/browser updates in the meanwhile (that I have noticed, version numbers are the same last I recall). It also started happening for the posters here around the same time, so I suspect some change on SE's side is causing this.
    – bad_coder
    Sep 20 at 3:28
  • It is quite severe on this one (on TeX - LaTeX). Though it may be a coincidence as the problem is intermittent. (You may have to wait a bit before it is available for trials.) Sep 20 at 12:12
  • Unable to repro using FF on Mac.
    – Luuklag
    Sep 20 at 19:24
  • @Luuklag: Which post did you try it on? I still get it on the TeX - LaTeX one. (2021-09-21T093106Z+0), e.g. using arrow keys up/down. Sep 21 at 9:31
  • 1
    @P.Mort: It's so bad that when now typing elsewhere, when I double-enter and go up, I expect a delay! Wonder why it wasn't status reviewed.
    – ymb1
    Sep 25 at 19:39
3

I've encountered this bug mostly on SO but also on SE (using Windows 10 Pro version 20H2 with Firefox 92.0). It's exactly as described. I'm under the impression it's not a delay but the cursor blink that isn't reset when you change line. It does happen most times when going upwards in the text instead of down, in the blank lines between paragraphs and code fences.

I just tried reproducing it in the below example and it happened a couple of times (less than 10%). It happens almost 80% of the time when I use userscripts (Roomba Forecaster, UnclosedRequestReview and SO Close Vote Request Generator with Violentmonkey).

A paragraph.

A code fence.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .