15

Update 17:57Z

The issue appears to have been resolved. The POST data is sent with two keys: fkey and closeReasonId.


I'm attempting to review an item in the Code Review SE reopen queue. After opting to leave the post closed, I select a reason and then click the button labeled Keep Closed an error notification is displayed at the top of the screen. In the console, I see the request received a 418 response. Can the response be a 2xx response soon, please?

review queue response attempt

This is occurring in Win10 & Mac OS 11.6 FF 93.0 64-bit, as well as Brave Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64), plus Safari 15.0 (16612.1.29.41.4, 16612), Chrome on iOS (with wifi disabled), MS Edge 94.0.992.50 (Official build) (64-bit) and Opera 80.0.4170.40 (x86_64).

It also happens in the Stack Overflow reopen queue.

After inspecting the POST request, it appears no POST data is getting submitted when opting to leave a question closed. When opting to reopen a question, the POST data contains 5 fields: taskTypeId, taskResultTypeId, fkey, postCommentId, and taskResultSubtypeFlags.

no post data

10
  • 1
    Can you try refreshing the page and trying again?
    – Catija StaffMod
    Oct 19 at 15:53
  • I refreshed the page, tried again and still got the same response. I even tried clearing cache and doing a hard reload - it still yielded the same response.
    – Sam Onela
    Oct 19 at 15:54
  • Disable all browser extensions (or Grammarly, if you have) and try again? Oct 19 at 16:02
  • I tried in private mode in Brave (Chromium) so no extensions are loaded, as well as Safari and Chrome on iOS (with wifi disabled), which have no extensions installed - the issue persists there as well.
    – Sam Onela
    Oct 19 at 16:09
  • 7
    Happening for me, too, in the Stack Overflow Reopen queue (Windows 10, Edge). Disabling all user-scripts doesn't help. Oct 19 at 16:38
  • 2
    Thanks for reporting - I'm looking into it right now. Will keep y'all updated.
    – kristinalustig StaffMod
    Oct 19 at 16:41
  • Not sure when it started. Things were fine, yesterday, and others seem to have been able to review today. Oct 19 at 16:42
  • 2
    @AdrianMole - I mean, Your Majesty - perhaps the users have been able to review today as long as they opted to reopen, which appears to not be missing POST data.
    – Sam Onela
    Oct 19 at 16:44
  • @kristinalustig after reloading it appears to send the POST data now.
    – Sam Onela
    Oct 19 at 18:00
  • 4
    FWIW this did help us find a different but somewhat related bug that existed with inbox notifications for posts that get left closed in the Reopen Queue so double thanks for reporting this issue!
    – kristinalustig StaffMod
    Oct 19 at 18:34
10

Glad to hear the fix worked! It was a "this is weird" issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .