On mobile, the "close as duplicate" dialog adapts its size according to a nominated original with all its answers (with quite a lot of content sometimes if the original question is very popular). So it's necessary to scroll all the way down to get to the "Vote" button.

On the desktop, the dialog is fixed-sized and all the stuff is inside this frame.

This is how it looks like (the screenshot are the entire screen without upper-status bar)

  1. I select a Close a duplicate option and see this dialog. Note that it is a) full screen, b) bigger than screen.

    enter image description here

  2. I select a question about ternary operator as original. The question with its answers is downloaded into the dialog. Note: there are 28 answers.

    enter image description here

  3. Now I have to scroll down all the answers (maybe not all 28 but at least 10 it was, I just didn't count) until I see the Flag button. The scroll indicator is marked with the green arrow.

    enter image description here

  4. And then the bottom of the dialog appears.

    enter image description here enter image description here

  • 2
    The mobile view is in the process of being deprecated: better to switch to the responsive view, which doesn’t have this problem. You can find the option “Enable Responsiveness” in the footer of any page. Feb 1, 2022 at 7:29
  • @TheAmplitwist I presume it is enabled because I only see the option "Disable Responsiveness".
    – Neumann
    Feb 1, 2022 at 7:31
  • 2
    @Neumann I can't reproduce when emulating mobile (using Chrome dev tools), this is what I see, which appears to have fixed height like on desktop. Can you please take screenshot and share it? Feb 1, 2022 at 7:46
  • @ShadowWizardHatesOmicron Now select any question.
    – Neumann
    Feb 1, 2022 at 7:47
  • @Neumann Oh… I see the same as Shadow on mobile, and selecting a question from the duplicate list also doesn’t change the size of the modal for me. Could you share a screenshot of what you’re seeing? Feb 1, 2022 at 7:50
  • @TheAmplitwist i added screenshots.
    – Neumann
    Feb 1, 2022 at 8:01
  • @Neumann Thanks! From the screenshots it appears that responsiveness is disabled. Could you please double-check which option you see in the footer, is it to enable or disable responsiveness? Feb 1, 2022 at 8:07
  • 1
    This is definetly the mobile web view, which is being discontinued as @TheAmplitwist already mentioned.
    – Luuklag
    Feb 1, 2022 at 8:08
  • @TheAmplitwist responsive design and mobile view are two different things. Having responsive design enabled does not "override" the mobile web view. Feb 1, 2022 at 8:11
  • 1
    @Neumann what you need to do is tap the "full site" link that you see in the bottom of the screen, then responsive design will kick in. Feb 1, 2022 at 8:12
  • after playing around with enable/disable, full size etc. I got another dialog which looks different and does not change. Then I cleared all browser data and on "fresh" browser the dialog's behaviour is again the same as described in the question.
    – Neumann
    Feb 1, 2022 at 8:13
  • @ShadowWizardHatesOmicron Then why isn't that "full site" not activated by default?
    – Neumann
    Feb 1, 2022 at 8:14
  • @Neumann because you're using mobile device. But at least once you tap "full site" this is saved permanently, on that device. Feb 1, 2022 at 8:17
  • @ShadowWizardHatesOmicron Yes. And on mobile device the Close as Duplicate dialog behaviour is is not as good as on desktop. Which the subject of my post.
    – Neumann
    Feb 1, 2022 at 8:21
  • 1
    As others said, the mobile view is very old and not good, which is known to SE and that's why they worked for long time on a responsive design that works much better. But until it's 100% complete, they can't just remove the mobile web view, so those on mobile device who want to enjoy the new design, still have to manually switch to "full site". While not ideal, I don't think it's very bad. Feb 1, 2022 at 10:46


Browse other questions tagged .