On a mobile (iOS) device using Safari, when I attempt to edit the tags on a question using the "edit tags" link, I get a pop-up saying "An error occurred when fetching the tag editor". I can use the normal "edit" link to edit the tags successfully. The issue does not happen on a desktop browser.

I'm not sure if this matters, since the pop-up happens either way, but I tried in Safari with both "Request Desktop Website" mode and "Request Mobile Website" mode.

I can reproduce the issue from both a Wi-Fi and a cellular connection on the mobile device. I can also reproduce the issue from the Chrome browser on the mobile device.

I'm using iOS version 15.2.1, which I think translates to Safari 15. I do not have any Safari Extensions installed, and I have not changed any of the "Settings → Safari → Advanced → Experimental Features" from their defaults.

I encountered this issue on Unix & Linux and do not yet have enough reputation points anywhere else to test on another site.

Screenshot of the pop-up:

Screenshot showing the error message "An error occurred when fetching the tag editor".

  • No repro on Chrome on Android.
    – Luuklag
    Commented Feb 15, 2022 at 12:40
  • 1
    I don't know how to see source code on Safari, but in a desktop browser looking at the page, I see javascript references to a cachebreaker: "js/inline-tag-editing.en.js":"c0cbc31e5702". Is it possible that I have received a stale or broken javascript file somewhere? Should I add this information to the post? If so, how do I get that page source code information from Safari? Commented Feb 15, 2022 at 13:07
  • 1
    Using the cool hack at apple.stackexchange.com/a/417701/379195, I appear to have the same "js/inline-tag-editing.en.js":"c0cbc31e5702" in Safari as in the Desktop browser (Chrome). Commented Feb 15, 2022 at 13:19
  • 1
    I am on iOS 15.2.1 using Safari and can't reproduce your issue. I fiddled with a few settings, but can't get anything to trigger. I have js/inline-tag-editing.en.js":"c0cbc31e5702" as well so that's not it I think.
    – ColleenV
    Commented Feb 15, 2022 at 14:30
  • Thanks, @ColleenV! Just to rule variables in or out; were you a moderator on the site you tried it on? Did you have 2k rep (or whatever the "immediate edit" privilege level is there)? Commented Feb 15, 2022 at 14:35
  • I'm pretty aggressive in blocking trackers and unnecessary cookies. If you accept more of those things, maybe one of those is causing a problem? I am not a mod on the site, just a 10k user. I use the inline tag editor a lot.
    – ColleenV
    Commented Feb 15, 2022 at 14:38
  • I'm with ya; I use some blockers on my desktop browser (which has enough allowed to use SE), but nothing additional (that I'm aware of) on the iOS side. Thanks for helping to narrow down the issue! Commented Feb 15, 2022 at 14:42
  • Which site do you have the problem on? SO is quite different from the sites I have enough rep to test on, so it could be something specific that site's design? Can you test on more than one site?
    – ColleenV
    Commented Feb 15, 2022 at 14:46
  • Well, since the error likely means some JS file being blocked, maybe something in your connection is to blame. Can you try other connection/WiFi? Commented Feb 15, 2022 at 14:56
  • I use the DuckDuckGo browser as a backup for Safari. It's pretty lightweight and blocks a lot of stuff right out of the box. The editor works for me in that browser as well. That would narrow down whether it's some setting in Safari, or whether, as Shadow mentioned, it's something about your connection. I use a third party VPN, which might be preventing some other "helpful" blocking.
    – ColleenV
    Commented Feb 15, 2022 at 15:01
  • hmm... I'm afraid there's another possible reason, of malicious app hijacking files/traffic/dunno what, causing mess. Can you maybe check the device for any possible app that might do such things? Commented Feb 15, 2022 at 15:20
  • I've love to say "good thought!" again, but I can't bring myself to it :) Since it's literally a little black box, I'm not sure how to rule this in or out. I've rebooted the device with no change in behavior. I'm open to suggestions on anything to try! Commented Feb 15, 2022 at 15:33
  • 5
    We are aware of what's causing this issue and it should be fixed as we remove the last vestiges of the mobile layout and the connections to it. Apparently, instead of having one marker for when something should show a mobile version, we had... many... and it's going to take a bit to eradicate all of them.
    – Catija
    Commented Feb 17, 2022 at 16:48
  • 1
    @JeffSchaller did you try getting help on SO? ;) Commented Feb 17, 2022 at 18:28
  • 1
    A related post on Meta Stack Overflow: Edit tags not working and comment flag icon missing in Mobile.
    – Martin
    Commented Feb 20, 2022 at 12:08


You must log in to answer this question.

Browse other questions tagged .