7

(Note: apparently this has been reported already in this answer on the New responsive Activity page, along with at least 215 answers and no feedback on this specific bug.)

I recently earned a badge on a few different Stack Exchange sites. My profile page of these sites now shows the "Congratulations! You've earned ..." message:

Congratulations

However, if click on "Track the next one", I get a popup showing all tag badges instead of the normal badges. I can't select either of the suggested badges, but since I cannot see the other ones, I cannot choose my next badge to track. This has worked correctly in the past, so something seems to have broken.

Select your next badge

NB: The "Let us pick" button still works fine, and once a new badge is picked, the "Next badge" gear is displayed again, which can be used to select another badge from the available badges. The problem only affects the "Track the next one" button.

PS: It seems that in some cases (as reported here), the list is not populated at all. This seems to be a special case, where there are no tag badges to choose from, for example on private betas because there are no badges with 100 questions yet).

9
  • 2
    This is result of the new responsive design. Already reported and ignored, so chances for a fix are somewhere around zero. (Due to other very annoying bug, browser won't jump to the linked answer, so you'll have to search the page for "Track the next one" to find the answer with the bug report.) Mar 16 at 7:58
  • @ShadowWizardSaysNoMoreWar, thanks for the link to that post. I had searched for this topic before posting, but since that's an answer to a question (between 215 different answers) I didn't find it. I suspected that it's related to the recent site changes, since the problem first occurred after these changes. However, not sure why this couldn't be fixed.
    – wovano
    Mar 16 at 8:12
  • It can be fixed, sure, but the developers moved on, working on whatever their boss tell them to work on, and bugs in old code (more than few weeks) are just ignored, or pushed to some endless TODO list. (Which is exactly the same as ignored, with thousands of bugs, and one bug fixed every few months, will take hundreds of years to clear the list) Mar 16 at 8:21
  • 1
    Does this answer your question? New responsive Activity page
    – Luuklag
    Mar 16 at 8:35
  • 3
    @Luuklag and no, this is not a duplicate, since answers on the original announcement are ignored for a while, closing as dupe is death sentence to the bug report. It's relevant only in the first few weeks when it's still fresh and the developer actually monitor the answers. Mar 16 at 8:43
  • 2
    Does this answer your question? On private beta sites the "Select your next badge" popup isn't populated from the "Track the next one" button, but works fine from "Let us pick" - that recent signpost makes it easy to find.
    – Rob
    Mar 16 at 9:06
  • 1
    @Rob, that's similar but not exactly the same. It could be that that question is a special case of my question, in the case that there are no suggested tag badges to show (which I think is the case if you've never received an upvote, since then the system wouldn't know which tags are relevant for you). It could also be a different (but related) bug. Note that that answer is also specifically about private beta sites, which my question is not. I observed this on Code Review, Ask Ubuntu and a few other sites as well.
    – wovano
    Mar 16 at 9:18
  • 2
    @Rob, ah, I just read the comment under that question: "the beta site has no tag badges to track because there are no badges with 100 questions yet." So it seems the bug (as described by me and here) is applicable for all Stack Exchange sites. In cases where there are no tag badges to track, this will result in an empty window, as mentioned in the question you mentioned.
    – wovano
    Mar 16 at 9:23
  • 1
    @ShadowWizardSaysNoMoreWar re: "Due to other very annoying bug, browser won't jump to the linked answer", not really a bug, it's because there are images loaded after the browser jumped to the target answer, pushing the answer further down. The workaround is to close the tab and reopen it (only works if the browser cache is enabled since the images are already loaded) Mar 16 at 12:53

0

You must log in to answer this question.

Browse other questions tagged .