16

This is how it looks like on any page1 except the chat page:

Image of Stack Exchange menu with site icons included

The site icons are visible here, but on the chat page2, these icons seem to have disappeared (the alignment is messed up as well):

Image of Stack Exchange menu on the chat page with site icons missing

This also happens in the reputation and inbox dropdowns.

I'm using Chrome (version 102.0.5005.115) on Windows 11.


1 The dropdown is accessible by clicking on the icon in the rightmost corner of the top nav.
2 This can be accessed by clicking on the Stack Exchange button in the leftmost corner of the top nav on the chat page.

6
  • 4
    I can reproduce this with Safari regardless of which site I access the chat page from, including Stack Overflow, Meta, ELL.
    – ColleenV
    Apr 1 at 11:56
  • 2
    I can also repro this when I force Chrome on Android to request the desktop version.
    – Luuklag
    Apr 1 at 15:57
  • 2
    I miss the old top bar :(
    – nicael
    Apr 1 at 16:03
  • @nicael web archive. Apr 1 at 18:00
  • 3
    Looks like the recent fix added this new bug. :( Apr 1 at 19:17
  • Regarding bounty: waste of rep, it's already in review, really nothing more we can do. (I place bounties on bugs/requests without status at all, trying to draw the staff to review them, at least.) Jun 15 at 7:06

1 Answer 1

6
+50

For anyone who can't wait for 6 to 8 weeks it will take for this to get fixed, here is a userscript to repair the broken window. It is as simple as adding the class s-topbar to the topbar-wrapper once the site-switcher is loaded.

Code on Github | Direct install

Code for the curious

// ==UserScript==
// @name         Fix chat icons
// @namespace    https://meta.stackexchange.com/users/158100/rene
// @version      0.1
// @description  Fix chat icons in site switcher
// @author       rene
// @match        https://chat.meta.stackexchange.com/
// @match        https://chat.stackexchange.com/
// @match        https://chat.stackoverflow.com/
// @icon         https://www.google.com/s2/favicons?sz=64&domain=stackexchange.com
// @icon         https://www.google.com/s2/favicons?sz=64&domain=stackoverflow.com
// @grant        none
// ==/UserScript==

(function() {
    (new MutationObserver(function(mutations) {
        document.querySelector('.topbar-wrapper').classList.add('s-topbar');
    })).observe(document.querySelector('.js-topbar-dialog-corral'), {
        childList: true,
        subtree: true
    });
})();

Visit Stack Apps for more awesome fixes or share your own!

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .