13

The Stack Snippet React version is outdated to such an extent that using a CDN link has become mandatory.


Stack Snippets provide React 16.6.3 as highest version.

However;

  • React 16.6 is a very old minor, 16.14.0 has been around since October 14, 2020
  • React 17 has been released more than a year ago (October 20, 2020)
  • React 18 has been released previous month (March 29, 2022)

Since most of the StackOverflow / CodeReview questions are about React Hooks we're kinda force to use a custom CDN link to create snippets.


As suggested in this 2 year old meta question about improving React support:

Can the React version be bumped to include at least a Hooks supported version? (Minimal 16.8)


enter image description here

1

0

You must log in to answer this question.

Browse other questions tagged .