11

I was looking at the revision history of the question "Is all ordinary mathematics contained in high school mathematics?" on MathOverflow (revision history, edit suggestion). I was curious what was actually the difference between the old and the new title - the revision history shows difference between the titles in the two revisions.

So I tried to check SEDE - to see what titles are shown in the Text field of the PostHistory table. Then I realized that the edit isn't shown in the PostHistory table at all (among the entries for this post).

The edit was made on July 24 - the database was updated since then. (SEDE shows "Data updated 2 days ago". There were some problems with SEDE, but according to answer there, they should be resolved now: Weekly SEDE refresh stuck at Gaming.SE. When I check the most recent post in database, I see some posts made on July 31.)

2

1 Answer 1

8
+50

Well, this is no fun.

The PostHistory table is fine.

SEDE result with 6 rows and column userid instead of User Link

All the records are there. Notice how UserId is no longer a magic link, User Link. Having the User Link magic column magically makes rows go up in smoke.

I tried to replace the User Link with the somewhat less magical manual link build option (SEDE Query):

 case when userid is null then '?'
  else
     concat('site://users/'
           , UserId 
           , '|'
           , (select displayname 
              from users 
              where users.id = posthistory.userid))
   end [User], 

and then I'm getting the result you and I expect.

User column is linked

So, to answer your question: No, there is no edit missing. Instead a SEDE feature that is supposed to make things a bit easier is playing confusing tricks on us. Now why it does that is something I go dig into next ...

In your original query you have:

UserId AS [User Link], UserDisplayName,

If I add a space after the ] or move the whole UserDisplayName, to the next line:

UserId AS [User Link], 
UserDisplayName,

your original query works.

2
  • 1
    Great ... now I'm wondering how many queries are affected by this ...
    – Glorfindel Mod
    Aug 4 at 19:35
  • 2
    @Glorfindel we can't know. We don't have access to stored queries except scraping. I suspect the problem is either in QueryRunner or in ParsedQuery but none of the fail cases I imagine would lead to the query returning less rows.
    – rene
    Aug 4 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .