2

When reviewing some questions, I saw this:

Enter image description here

Is this a bug? The user avatar characters aren't even fully visible either.

Related: Alt text overlap for Top Network Askers with broken avatar

6
  • 5
    The user profile image didn't load. The design assumes it does. What is thrown at you is the image title in the limited space allowed for the image. That is never going to fit. Maybe these image loads need to be controlled by javascript so it can show a fallback image when the real profile image doesn't load. Does the image never load for you for that user?
    – rene
    Aug 7, 2022 at 8:21
  • 2
    It doesn't load for me either so it is not a local issue. The image does come from a google domain so I assume the user removed the image they previously had uploaded to google
    – rene
    Aug 7, 2022 at 9:00
  • 3
    I don't think we really need any alt text there, ie alt="" with everything in the same link. The image is already described enough by the text next to it (username), since it's an image for that user. This was already requested in User avatars are noisy in screen readers.
    – Laurel
    Aug 7, 2022 at 11:06
  • I stumbled across a review item just like the one reported
    – bad_coder
    Sep 27, 2022 at 22:29
  • @bad_coder, the linked item shows perfect avatars for me. The user there their picture originates from facebook, so perhaps thats blocked for you?
    – Luuklag
    Sep 27, 2022 at 22:31
  • @Luuklag see the answer, it's about the effect (that can be mitigated) of having blocked avatars. It's worth reporting since it's also likely a common use case.
    – bad_coder
    Sep 27, 2022 at 22:43

1 Answer 1

1

It's worth documenting this further (if you've disabled fetching avatars from social media to not be tracked) the "bug" becomes more visible in DarkMode. Maybe there's been some change since the original report because apparently the alt text is also longer now. See this example review item, as shown in the screenshot:

top of a review item in the queue

Using Windows 10, Firefox 104.0.2 (64-bit), 1920x1080, rev 2022.9.27.33359

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .