14

Bookmarks Are Evolving Into Saves is not yet published.
But when I tried to hit the URL https://meta.stackexchange.com/users/saves/<userid>, the saves page is opening and I'm able to add a few lists to my profile too.

Before the full functionality was published, able to use partial features.

Saves page

7
  • 4
    Although the standard current in place of the user ID doesn't seem to work (yet).
    – Mithical
    Sep 16 at 14:38
  • 6
    ... and trying the userid of someone else gives a nice json error response.
    – rene
    Sep 16 at 14:39
  • 2
    @This_is_NOT_a_forum FWIW I've edited a link to this answer into my answer there because it's less about "Here are some exposed problems, could they be fixed?" and more about "Hey, some of your commits are leaking to production when they look like they're not supposed to be. Can you review them?"
    – Spevacus
    Sep 16 at 15:04
  • This is like baking a cake, and inviting all the kids nearby to eat it while it's still only half baked. ;-) Sep 16 at 16:15
  • 4
    Great analogy @ShadowTheKidWizard. I'm going to borrow it ๐Ÿ˜. Kids knew that a cake was coming and most did not know where to look, only some did ๐Ÿ˜‰
    – tanj92 Staff
    Sep 16 at 16:50
  • 1
    @tanj92 hehe, yeah, only the smart kids! Sep 16 at 17:41

1 Answer 1

13

Thanks for bringing this to our attention. We were conducting rounds of internal testing this week and enabling the feature resulted in the URL being live for those who were able to directly access the page. This was not intentional until as we were going to save this for when we were ready to launch (hint: it's soon ๐Ÿ˜) but we'll leave it up for now.

I'm impressed Meta was able to find the URL this quick but we'll do better next time ๐Ÿ˜‰.

I will be updating the status to . Once we launch, I will change it to .

6
  • 3
    So you really don't have test/dev environment, if you do internal testing out in the open. Sep 16 at 16:43
  • 4
    We have dev environments for testing which we conducted on, but we wanted to perform testing on production behind a site setting to address any issues that we may not have seen in a dev environment. The URL was accessible but wasn't exposed on profile pages.
    – tanj92 Staff
    Sep 16 at 16:47
  • 2
    OK, not ideal, but why didn't you disable the access once test was done? Also, the status-completed tag here is wrong, if you leave this working, it means the reject the bug, or saying it's by design. Nitpicking, I know, but... Meta. :-) Sep 16 at 17:40
  • 3
    @ShadowTheKidWizard We were still conducting testing for a few more items. I've updated the tag to status-planned. Once we launch, I will change it to status-completed. Thanks for the correction.
    – tanj92 Staff
    Sep 16 at 18:00
  • I mean, the bug is simple: we can access a page that we should not be able to access yet. As long as we can still access it, the bug isn't "fixed". When launched and we will have access as planned, the bug will become "by design", as this is how the system should actually behave. Sep 16 at 20:17
  • 1
    Anyhow, I did learn a lot about your internal working from this "mini ordeal", so thanks for sharing and explaining. Sep 16 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .