6

On sites where I see advertisements the vertical space between the ad and the start of the question is very small. Example from SFF:

enter image description here

This is distracting to read, and it seems to be inconsistent with the vertical spacing used everywhere else in the design.

A similar effect occurs for sidebar advertisements, although it is less prominent (from Arduino):

enter image description here

Browser: Firefox 106.0.3 on Ubuntu, but it also occurs in Chrome.

Suggested fix: make the space a bit bigger.

8
  • @AaronBertrand indeed, most likely deleted for some reason. You might be able to find it using deleted:1 in search, not sure if the "staff" bit is enough without a diamond though. :) Nov 2, 2022 at 13:54
  • @AaronBertrand I read Meta.SE regularly but I didn't see the previous report, sorry - the problem itself has existed longer though, at least one or two weeks now.
    – Marijn
    Nov 2, 2022 at 13:58
  • 3
    @ShadowTheKidWizard I can see deleted posts, but I've since discovered that I saw this in an internal Slack conversation last week. So close. I don't want to disclose too much but essentially the space that is missing is usually reserved for a "Report this ad" link, and the behavior is different depending on whether you are logged in. They're aware there's a fluctuation but I don't have any info about fix/timeline/etc/
    – Aaron Bertrand Staff
    Nov 2, 2022 at 13:58
  • @AaronBertrand hehe. so we can't report internal SO ads, that make sense. Still, better design choice would be to add a margin when there's no "report ad" link. Nov 2, 2022 at 14:00
  • 3
    @ShadowTheKidWizard Of course. They're still investigating where the margin goes.
    – Aaron Bertrand Staff
    Nov 2, 2022 at 14:01
  • 2
    @Shadow I think it's not related to the ad being internal, the second example I put in the question (about the sidebar) also doesn't have a report ad link while this is an external ad. The problem is that the link is not shown at all when you are not logged in (which indeed I am not in both SFF and Arduino).
    – Marijn
    Nov 2, 2022 at 14:03
  • 3
    Agreed, whose ad it is is not the issue.
    – Aaron Bertrand Staff
    Nov 2, 2022 at 14:12
  • The issue seems to be fixed now.
    – Marijn
    Nov 5, 2022 at 17:15

0

You must log in to answer this question.

Browse other questions tagged .