12

Tapping on the message from inbox doesn’t mark it read anymore. Is it desired behavior?

enter image description here

As far as I remember before inbox renewal, tapping on the item led to mark that item read (simultaneously with the redirecting to target object). Now only the redirection is done, and I need to manually tap on envelope icon to mark the message as read.

Tested on iPadOS 16.2, Google Chrome

Not reproducible on Android.

According to the comments below looks like an Apple products related issue.

Here's additional animation to see how it "works":

enter image description here

13
  • 4
    It's possible you received multiple comments on the same post. The dropdown will initially consolidate those multiple notifications into a single entry, but once you've read the first one, the notifications for the other comments will remain unread and the read one will be separated. Jan 21, 2023 at 9:29
  • I think you can reproduce on this question Jan 21, 2023 at 9:57
  • ...since I just commented on it twice Jan 21, 2023 at 9:58
  • No repro, maybe some userscript. Jan 21, 2023 at 11:07
  • I tried on several different desktop browsers. You did not mention it was iOS in the original revision. I don't have that handy at the moment, so I cannot easily check there. Jan 21, 2023 at 11:09
  • 1
    @ShadowWizardChasingStars I never used userscripts. Especially on iPad. Jan 21, 2023 at 11:15
  • 5
    @αλεχολυτ I frequently have this problem, too. Sometimes it works, sometimes it does not. (Firefox 102.7 ESR on macOS 11.7) Jan 21, 2023 at 13:23
  • Related announcement: Inbox improvements are live. Left-clicking or middle-clicking an unread notification should mark it as read, though right-clicking it won't. Not sure if this is an iPad-/iOS-specific issue, or if it's the same issue indicated by Sonic's first comment (which has also been reported in an answer on the announcement I linked).
    – V2Blast
    Jan 23, 2023 at 20:37
  • 1
    @V2Blast Left clicking also supposed to work for inbox notifications about followed posts? I always have to manually mark them as read. Left click never works for them. Jan 23, 2023 at 20:47
  • 1
    @samcarter_is_at_topanswers.xyz Yep, it should work. It seems to work when I tested it just now by marking a followed-post notification (for a new answer on it) as unread, and then left-clicked on it – it did mark it as read for me.
    – V2Blast
    Jan 23, 2023 at 21:01
  • 1
    @V2Blast Not working for me with Firefox/macOS i.stack.imgur.com/wG3hh.gif Jan 23, 2023 at 21:19
  • 6
    This has never worked for me. I always have to click mark as read. Safari, Mac OS Ventura (13.1).
    – Joe
    Jan 24, 2023 at 16:52
  • 1
    As for the bug itself, probably the tap action of iOS sends different code to the browser, and SE "listens" only to codes of mouse click events in the part responsible to mark as read. May 30, 2023 at 7:54

0

You must log in to answer this question.

Browse other questions tagged .