This has been reported quite a few times over the years, both with Chrome and Firefox (and maybe others, I did not read all the comments).

Since it is driving me crazy (but it's not like there is an alternative to Stack Overflow out there), I thought I would report it again.

What happens

I keep getting logged out of Stack Overflow, forcing me to log in almost every single time I come back to the tab (even if I did not close it). This also means that I get the damn GDPR popup every. single. time.

Right now, I am running on Firefox 111.0 (64-bit), but it started on an earlier version. The links above show that other people have experienced the same on Firefox and Chrome in the last decade.

Note that it has been working flawlessly for 10+ years on different browsers, and for 2+ years on this exact setup. The bug started appearing a couple months ago.

Moreover, it only happens for Stack Overflow. I am logged in tens of other websites, and they work flawlessly (suggesting that it's not just my browser losing all the cookies). Also it seems like I don't get logged out of other Stack Exchange websites.

My setup

It happens on Firefox 111 (but it was also happening with 110 and some other version), but I don't have issues with Brave (i.e. Brave stays logged in for weeks).

I am not using many extensions on Firefox:

What I tried to fix it

  • Login with username/password
  • Login with Google SSO
  • Disable my ad blocker
  • Remove cookies, cache, offline web data and site settings
  • Contact SE support, which closed my ticket right away, saying something like: "it's probably your ad blocker, try another browser". Because it's closed, I can't answer, so the message I get is really "screw you, we could not care less".
  • Create a new Firefox profile (and re-add my extensions and configs). It worked for a week, and now it's back to the original problem.


Did it ever happen to you? Did it stop happening/did you find a fix?

  • 2
    I had this - apple.stackexchange.com/questions/454563/… - but there was a lot of juggling cookies/ad blockers before I found clearing the other app's data fixed it. Fairly unsatisfactory methodology, I'm afraid, though it worked in the end. [I reported it here first, but it received little love, so I deleted]
    – Tetsujin
    Commented Feb 22, 2023 at 8:16
  • 3
    Well, this is something on your end. In your case, might be some ISP quirk, I've heard of cases where the ISP cleared the browser cache once in a while as some odd "security" measure. So before blaming SE, try talking with your ISP, or browsing with different provider, e.g. WiFi of some external provider. Commented Feb 22, 2023 at 14:10
  • 2
    The most recent occurance that I could find was since Feb 3, 2023 Commented Feb 22, 2023 at 15:41
  • 6
    How would my ISP clear my browser cache? I never said it is not on my side. I said that over the tens of websites to which I am connected, the only one that keeps logging me out is SE. So somehow, it feels like it is specific to SE, right? If e.g. my browser was losing the cookies, I would see that on other websites. Commented Feb 22, 2023 at 17:06
  • 1
    @JonasVautherin: That information in the last comment ought to be in the question. Also an example of a particular browser in a particular version for which this happened (but **** without **** "Edit:", "Update:", or similar - the question should appear as if it was written right now). Commented Feb 23, 2023 at 1:15
  • 1
    Can you use a different browser for Stack Exchange for a while? Just to narrow it down to a browser-specific issue rather than an account issue? Can you also try creating a new "profile" in Firefox (if such a thing exists, I haven't used Firefox for a while) with factory settings and no extensions installed? There could be a setting or extension that doesn't play nice with SE. Commented Mar 1, 2023 at 15:15
  • 1
    A way to start afresh (without abandoning the old setup) is to create a new "profile" in Firefox. Though it probably does require repeating some configuration steps to be convenient. But it could be way to get a state that works (presuming it is a problem with the Firefox configuration). And then it could be slowly changed to be more like the old configuration (original "profile"). The states can be preserved by backing up the corresponding folder (thus easier to return to a previous state). Commented Mar 23, 2023 at 18:23
  • 1
    This is not a bug report. This is my post to report my problems, describing my setup and the steps I have tried, hoping to get suggestions by others. Are you the kind to complain on StackOverflow because questions there are not new fundamental philosophical questions about programming, but rather questions about "why does my code not work when the similar example does"? Commented Mar 27, 2023 at 6:24
  • 1
    @This_is_NOT_a_forum: I have been doing what you suggested (a new profile), and so far so good :-). I think that would be a reasonable answer, given that I'm unlikely to ever understand what failed in my main profile! Commented Mar 27, 2023 at 6:26
  • 1
    @This_is_NOT_a_forum: so creating a new Firefox profile helped for a week, and now it's back to square zero: I get logged out every few hours. Only StackOverflow, no other website. Commented Apr 6, 2023 at 11:56
  • 2
    I"m also having this problem. Firefox on Macos. By leaving the stackoverflow page open with the inspector displaying cookies, I've found that the "acct" cookie disappears from the cookie list after a few hours. It's not expiring; the expiration time is six months in the future.
    – Kenster
    Commented Apr 15, 2023 at 12:38
  • 2
    I managed to catch the warning Cookie “acct” has been rejected because it is already expired. in the firefox browser console, possibly corresponding to the cookie disappearing from the stackoverflow.com cookie list. It seems to have happened when my RSS reader extension refreshed a question feed.
    – Kenster
    Commented Apr 17, 2023 at 20:44
  • 1
    @Kenster did you accept all cookies, or only the "strictly necessary"? I have tried to "accept all cookies" and it feels like it's been better since then, somehow. Not sure if that's a coincidence or not. Commented Apr 17, 2023 at 22:37
  • 2
    meta.stackoverflow.com/questions/424244/… @JonasVautherin Try checking your browser console for warning-level messages (yellow background) saying "Cookie “acct” has been rejected because it is already expired". Go to Tools->Browser Tools->Browser console, then select "multiprocess".
    – Kenster
    Commented Apr 18, 2023 at 14:09
  • 1
    Yeah I don't have it (the "Cookie "acct"" message), but for now I'm also not getting logged out of StackOverflow, for some reason... I'll do it when that comes back Commented Apr 18, 2023 at 14:44


You must log in to answer this question.

Browse other questions tagged .