Today I logged in to stackoverflow and saw that my gravatar was again a "monster" and not my gravatar pic. I went to gravatar and the avatar was working fine.

I was using a username+stackoverflow@gmail.com address, (I really love the + addresses in gmail) and when I swichted it back to just username@gmail.com (which is also registerd at gravatar, as main account) the proper gravatar picture appeared. I tried to put the + address again to see if it was still not working, but now I got a "email address not valid" error...

So why are username+whatever@gmail.com emails not valid anymore?

closed as too localized by juan, Jeff Atwood Feb 8 '10 at 23:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    Jeff has some 'splaining to do. – Welbog Feb 8 '10 at 16:46

I'm currently using username+unicorn@gmail.com, and it seems to be working for me. Is that just my browser cache? Have I lost my unicorn?

  • weird.. its letting me do it again.. but now I LOST my unicorn... i mean, gravatar.. and yes, i DO have username+stackoverflow@gmail.com properly set in gravatar.. – bangoker Feb 8 '10 at 16:53
  • 1
    hmmmm looks like it ws MY cache.... I just deleted it and now my gravatar is on... it weird... – bangoker Feb 8 '10 at 16:55
  • @bangoker - well I can see your gravatar, and your e-mail is currently +stackoverflow... seems OK? – Marc Gravell Feb 8 '10 at 16:55
  • yeah, I dunno what happend.. maybe a little glitch and i was to fast to pull the ask-a-question trigger, but yeah, after deleting my cache I could see my gravatar as well. Thank you for the quick respond though! – bangoker Feb 8 '10 at 17:05
  • @bangoker, accept this answer please! – Arjan Feb 8 '10 at 17:25
  • 3
    The cache doesn't explain the error message reported in the question. @bangoker: You really did see that "not valid" message? – Gnome Feb 8 '10 at 17:26

Not the answer you're looking for? Browse other questions tagged .