4

The equation $x = \{y\}$ is supposed to render like this x = {y} but instead in the preview pane it looks like this x = y. The escape sequences for curly braces, \{ and \}, do not render correctly. This is a recent problem (I posted a question with curly braces a couple months ago and it rendered correctly)

This seems like a bug (unless there's been some undocumented recent change to MathJax?). FWIW, my browser is Chrome version 111.0.5563.65 (on Windows 10)

Update: I tried on the Edge browser and it works as expected. So this looks like a Chrome-specific bug

9
  • Welcome to Meta SE. FYI, a similar problem was reported about 6 days ago on the Mathematics Meta site at Why would escaped curly braces not be displayed by the mathjax plug-in?, although it's not clear from what's written there if it's an issue with just the preview, or also when the OP viewed the posted result. Mar 18, 2023 at 7:34
  • 1
    I hope I posted this in the right place? All the sub-sites (meta, vs math meta, etc.) is very confusing
    – NikS
    Mar 18, 2023 at 7:35
  • 3
    Due to MathJax being used on multiple SE sites then, as far as I know (and also based on what I've seen in several other questions here), posting here should be fine. Mar 18, 2023 at 7:36
  • Is it perhaps another one of them MathJax/Markdown interactions? Mar 18, 2023 at 16:01
  • 2
    Does it work if you submit the post? If not, is there a certain number of backslashes that does work?
    – Laurel
    Mar 18, 2023 at 16:36
  • Didn’t try submitting the question (don’t want to submit a mangled question) There’s no end to hypothetical workarounds I could randomly try, but I think I’ll let Stackexchange’s engineering department take it from here.
    – NikS
    Mar 19, 2023 at 0:01
  • Doubtful it’s a MathJax/Markdown interaction. Problem occurs even with just the simple equation mentioned in my post.
    – NikS
    Mar 19, 2023 at 0:04
  • 1
    If you do want to try in a real post, you can use the Math Sandbox.
    – Laurel
    Mar 19, 2023 at 11:08

1 Answer 1

1

It seems that preview has problems with backslash in several instances.

For example, if I try this text:

$\{x\}=\{y\}$

$r(ξ, \bar{ξ}) = \frac{1}{\#𝒢} \sum_{g ∈ 𝒢} r_0 (g(ξ), g(\bar{ξ}))$

$\begin{pmatrix}
x_1 \\ x_3 \\ x_3 \\ x_4 
\end{pmatrix}$

It either renders incorrectly or not at all in the preview after entering the question:

screenshot

However, after the question is posted, everything looks fine - the screenshot is below and people with 10k+ reputation points on Mathematics can see the question here:

screenshot

Once the question was posted, after clicking on edit, the preview behaves correctly:

screenshot

The examples used above are based on various bug reports, such as: Missing brackets in ${x}$ in drafts, not missing in the final question/product and Including a hash character (#) in a math equation causes it to not render (in new-question page). Problem with \\ - which is used as a newline in various matrix-like environments - was mentioned here: MathJax preview renders slowly and improperly. At some point in the distant past it was recommended to use \\\\ instead - but as you can see, \\ clearly works now in the final post; the problem is only in the preview before posting. See here: Using the align environment?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .