6

When viewing questions on the front page (after clicking Questions or viewing all questions for a specified tag), sometimes the last few characters of previewed text from the question body render incorrectly on Safari. The issue appears to be the ellipsis character "..." rendering on top of the last one or two letter characters in the text.

This happens on multiple sites on the Stack Exchange network. The descending "stems" of the letters look like they have blobs at the bottom, only when text from the question is displayed as a preview on the front page (the same characters look normal on the actual question page once you click on the question).

Screenshots of the letters "h" and "i" on the preview (distorted; circled in red) and the question page (normal; circled in green):

Enter image description here

Enter image description here

Screenshots of the letter "n" on the preview (distorted; red circle) and question page (normal; green circle):

Enter image description here

Enter image description here

This does not appear to happen on Firefox. Here are screenshots of what the ends of the preview text on the front page look like in Firefox, for comparison:

Enter image description here

Enter image description here

Here, you can see that while the ellipsis doesn't render on top of characters like it does on Safari, it does sometimes display under a hyphen, and sometimes after it. This may very well be intentional to best accommodate the precise width of the browser window.

7
  • 3
    Which hardware, OS, and browser?
    – tripleee
    Commented Aug 22, 2023 at 4:02
  • 1
    Mac mini M1, with OS Ventura, viewing the site in Safari Commented Aug 22, 2023 at 4:04
  • 2
    @tripleee Trying to reproduce the issue in Firefox revealed what is actually happening - the "blobs" are the ellipsis, rendering on top of the last character or characters instead of after them. This doesn't seem to happen with Firefox, only Safari. Commented Aug 22, 2023 at 4:15
  • 1
    The ellipsis on Firefox will sometimes render underneath (instead of after) a hyphen character when the window is dynamically resized, but that seems like it may be intentional. Commented Aug 22, 2023 at 4:18
  • 1
    I tried to repro but was unable to. My previews look quite different, with a typewriter font in the input text box. Where do you get the ellipsis? Are you using the Markdown editor? Any browser extensions or other plugins? Can you edit to provide repro steps (and probably also include other information from down here in the comments)?
    – tripleee
    Commented Aug 22, 2023 at 4:23
  • 2
    @tripleee Oh, my mistake! Not the editing preview, the preview as in the first few lines of text shown from the question's body when the question is displayed on the front page. I should have been more clear Commented Aug 22, 2023 at 4:27
  • 1
    I will edit that into the question. Commented Aug 22, 2023 at 4:27

0

You must log in to answer this question.

Browse other questions tagged .