Starting around 2023.09.17, I've been unable to access the review queue, recent inbox, or achievements using the top bar menu, when using TorBrowser. At the network level the response to the GET (for example https://unix.stackexchange.com/topbar/review?_=1695589457710) is a 403 Forbidden, and on the page I get this message over and over again:

Something went wrong, please try again.

I can still get to the same places the top bar would've taken me to, but to do that I have to use a direct link (for example https://unix.stackexchange.com/review/).

The same error occurs when trying to post an answer or a add a comment even if I go to the direct links.

It happens in all the Stack Exchange sites where I have an account. Creating new Tor circuits doesn't help, the behavior is the same: everything works but the top bar icons for inbox, reputation changes, and review queues.


After some checking, I'd say that @wizzwizz4 was right all along, about Cloudflare being at the root of the problem. From what I understand from their documentation on this issue, two possible solutions are:

  • to ask Stack Exchange to change the default protection level for Tor users

  • to set up Onion routing from Cloudflare to the Stack Exchange servers.

  • 5
    It's Cloudflare. Check the entry in the F12 Network tab, and select “view raw”: their anti-bot system wants to make sure these “automated” requests aren't automated – which, of course, they are, given that they're triggered by JavaScript. You see this on a lot of websites. (Nice spot, though!)
    – wizzwizz4
    Commented Sep 24, 2023 at 22:28
  • 5
    The usual workaround (open the offending URL in a new tab and pass the CAPTCHA) doesn't work, probably because the Cloudflare anti-bot isn't set strict enough for that to cause a false positive. (I wish Cloudflare had a “let me prove I'm legit” endpoint, for those of us who are using supported browsers, have a fast enough CPU for the PoW part, and can do the hCaptchas.)
    – wizzwizz4
    Commented Sep 24, 2023 at 22:33
  • Note that none of the dynamic parts work: check your user profile's Activity page, and you'll see those three dots endlessly there as well.
    – wizzwizz4
    Commented Sep 24, 2023 at 22:37
  • 3
    Hey Eduardo - are you still experiencing this? We made some configuration changes on Friday that should have addressed this issue so hopefully you're not having issues still. If so, please let me know and add any additional info that might have come up. Thanks so much for reporting this!
    – Catija
    Commented Sep 25, 2023 at 16:23
  • 4
    @Catija the issue persists as reported. I guess anybody can reproduce it just by visiting with TorBrowser (do change circuits though, just in case). And I just found out that I cannot add comments either, I had to move to the clearnet to post this (yes, most of the time I really kind of have to use Tor) Commented Sep 25, 2023 at 23:56
  • 1
    @EduardoTrápani I believe the issue stem from Tor Onion routing using IPv6 and the application back end that handles the top bar doesn't support it. Can you try disabling IPv6 in your Tor configs?
    – Josh Zhang StaffMod
    Commented Sep 26, 2023 at 23:18
  • 3
    @JoshZhang If a service is broken for IPv6 one would expect the AAAA records for the hosting server not to be published ... The Tor exit node will use IPv6 or IPv4 depending on the stacks available there, that's not something I can (know how to) change. Anyway, just in case, I changed circuits until I reached a supposedly IPv4-only exit node but the problem persists. Commented Sep 27, 2023 at 14:14
  • 3
    @EduardoTrápani I've confirmed due to onion routing that CloudFlare supports, some requests still come through IPv6. The access URL supports IPv6 but the back end application does not.
    – Josh Zhang StaffMod
    Commented Oct 2, 2023 at 15:30
  • @JoshZhang I will have to wait until the back end application is fixed then, the Stack Exchange sites have become uncomfortable read-only from Tor (I just added some information on the issue). I guess it might also become a problem for clearnet IPv6 users. Who knows... Anyway thanks for having looked into it! Commented Oct 2, 2023 at 23:03
  • 2
    @JoshZhang also same issue? Commented Oct 8, 2023 at 6:49
  • @JoshZhang Note that this is blocking one of our moderators from moderating. Please prioritize. Commented Jan 25 at 13:26


You must log in to answer this question.

Browse other questions tagged .