This started about 2 days ago, roughly when I first saw Cloudflare's "human verification" confirmation. (As a side note: this confirmation is asked from me once like every hour, which I believe is not intended.)

Many sites (maybe all except meta.stackexchange.com) don't render for me, static assets cannot be downloaded. I tried multiple browsers and incognito mode. I see the page content, but since CSS styles and scripts cannot be downloaded, the site is not rendered and not working correctly.

Example of what I see:

enter image description here

On Chrome's network tab I see HTTP 403 errors for static resource requests:

enter image description here

On Chrome's console I see net::ERR_BLOCKED_BY_RESPONSE.NotSameOrigin 403 errors:

enter image description here

  • 3
    Are you using Tor? Commented Oct 25, 2023 at 8:44
  • @ShadowWizardIsSadAndAngry No, I'm not using anything fancy (like Tor, proxy).
    – icza
    Commented Oct 25, 2023 at 9:13
  • 3
    Weird, something cause CloudFlare (the CDN host) to block you, so wonder why. Sadly only staff might know, so we'll have to wait for them. Commented Oct 25, 2023 at 9:53
  • 1
    Another idea, do you have any antivirus or security software that might monitor or mess with the requests? If so try to temporary disable it, just to see if that's the culprit. Commented Oct 25, 2023 at 14:12
  • @ShadowWizardIsSadAndAngry No antivirus or security software. And everything was working 2 days ago, no change on my computer since.
    – icza
    Commented Oct 25, 2023 at 14:17
  • What do you see when browsing directly to a blocked resource, e.g. this one? Commented Oct 25, 2023 at 14:20
  • @ShadowWizardIsSadAndAngry I'm not at home right now, will test and respond when I get back home.
    – icza
    Commented Oct 25, 2023 at 14:22
  • Do you have an ipv6 or ipv4 address? Commented Oct 25, 2023 at 14:27
  • "What's my ip" google query results in an ipv6 address, but I believe I have both.
    – icza
    Commented Oct 25, 2023 at 14:34
  • It appears that most or all of the Stack Exchange specific resources are being blocked (e.g., everything from cdn.sstatic.net, both JS and CSS). This is most likely to be done by your browser, a browser extension (which could be installed in both browsers), your operating system (e.g., firewall settings), or somewhere in the network connection you are using (e.g., work, ISP, country, etc.). It is likely not an issue specific to Stack Exchange, other than the block is on a domain that Stack Exchange uses. You will need to do investigation on your end to find where the block is and resolve it
    – Makyen
    Commented Oct 25, 2023 at 15:47
  • 1
    Given that these are "NotSameOrigin" responses, which is something that's enforced in your browser, the issue is almost certainly that something on your end is causing this problem.
    – Makyen
    Commented Oct 25, 2023 at 15:52
  • @ShadowWizardIsSadAndAngry "What do you see when browsing directly to a blocked resource, e.g. this one?" I see that JS file rendered as plain text in my browser.
    – icza
    Commented Oct 25, 2023 at 16:32
  • But wait, the site is "back", I see it correctly rendered now... I didn't change anything. Must have been an ISP issue, as the "desktop view" of the site from my phone also didn't work when using home wifi, but it did work when using mobile network.
    – icza
    Commented Oct 25, 2023 at 16:35
  • Thanks everyone for trying to help me. I think the question can be closed / deleted now.
    – icza
    Commented Oct 25, 2023 at 16:36
  • Actually better post what you did (browse directly to the file) as a possible solution (answer), it might have cleared some block, I don't think it's coincidence. Worst case someone will waste a click. :) Commented Oct 25, 2023 at 21:15

1 Answer 1


This is not completely an answer, but way too long, and might also contain the cause for the problem and a possible "half" solution.

It wasn't working for me for 2 days. I really didn't do anything, didn't restart my computer nor browser (didn't disable yoroi either), when I got back home, first I tried the JS resource link explicitly (which was failing on the Chrome's network tab) which rendered properly, then refreshed the StackOverflow tab and it was working correctly. First I thought that if I had do it the other way, StackOverflow would also work for the first time.

Then today I tried to refresh the StackOverflow tab, and again, same problem: it again did not work. Then I tried again the external JS resource: first showed me the CloudFlare confirmation, clicked "I'm a human", then the JS resource rendered properly (as plain text). Then I refreshed StackOverflow, and it started working again.

It's as if when I'm confirming "I'm a human" on StackOverflow domain, it's not enough for the external resources, I also have to confirm that for cdn.sstatic.net too.

Edit: Further findings

As written in the question, the CloudFlare verification is displayed to me every 30 minutes. Every time it is, the static resources stop working for me. I don't always notice it immediately because they are cached, but if I empty the cache (or more practically open the developer console in which case caches are not used), StackOverflow stops working again (as static resources cannot be downloaded again anymore). I have to again try to retrieve one of the static resources explicitly on a new tab (refresh if only displayed from cache), and do the verification. Then if I refresh StackOverflow tab, it works again.

  • 2
    So looks like this bug hitting again. I'll ping the dev there. Commented Oct 26, 2023 at 8:57
  • That "partial solution" is the best workaround I've yet found: I doubt we're going to find a better one any time soon.
    – wizzwizz4
    Commented Oct 26, 2023 at 12:08
  • The issue seems to have gone now, probably the human verification bug has been fixed.
    – icza
    Commented Oct 27, 2023 at 20:47
  • Apologies for late reply, I just returned from vacation. If you're getting a human verification every 30 minutes, you're either exceeding our rate limiters or CloudFlare is classifying traffic from your IP as malicious. If you're accessing Stack through your employer's ISP the aggregate traffic could be what's causing the rate limiter to kick in.
    – Josh Zhang StaffMod
    Commented Oct 30, 2023 at 17:39
  • @JoshZhang I was accessing StackOverflow from my home network. I had a couple tabs open, but I always do, never had any problems. I also don't run anything that would access CloudFlare. But again, the issue is gone now. Thanks.
    – icza
    Commented Oct 30, 2023 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .