14

The post below made me investigate the links at the bottom of the page.

Opt in or out of cookie tracking

To opt in or out of cookie tracking, scroll down all the way to the bottom of any page on Stack Overflow or a Stack Exchange Site. Under the “Company” heading click “Cookie Settings”. There you can change your cookie preferences.

Des's [Staff] Update to our Advertising Guidelines © CC BY-SA 4.0

I mistook the "Cookie Policy" link for the "Cookie Settings" link and discovered it was broken.

Oops! Something Bad Happened! page


The "Cookie Settings" link is sometimes accessible when JavaScript from cookielaw.org is disabled. If you have JavaScript enabled then a popup should show up.

8
  • 3
    Uhh, I don't really know how to fix my question. I misread "Cookie Settings" as "Cookie Policy". The "Cookie Policy" is the one which leads to a broken link, the "Cookie Settings" is only broken in you have JS disabled. I really need to learn to read but not really sure what to do to salvage the question now.
    – Peilonrayz
    Jan 15 at 17:53
  • That's ok, you managed to find 2 bugs in 1 post.
    – Mast
    Jan 15 at 17:57
  • 1
    The Cookie Monster got it. Jan 15 at 18:00
  • I would split them into two separate reports so they're easier for the team to address. Jan 15 at 19:01
  • 2
    @SonictheAnonymousHedgehog It's already under review and the team is aware of the situation. I'd leave it be unless the team explicitly asks for the items to be split up.
    – Mast
    Jan 15 at 19:54
  • 1
    @Mast That's true, but keep in mind that in the internal ticketing system the team uses, only the titles are saved, so it's likely that only the link mentioned in the title will actually get fixed. Better to have another request for the other button. (There was a past case where a site had requested blocking both questions and answers from unregistered users, and even though the body mentioned both, only questions were blocked; it was later revealed that that's because the title of the request only mentioned questions and answers were soon blocked after.) Jan 15 at 20:11
  • 1
    @SonictheAnonymousHedgehog There are multiple moderators looking over the Team's shoulder on this. Don't worry.
    – Mast
    Jan 15 at 20:16
  • 1
    @Mast well the mods should look over the Team's shoulder on more bugs then, if that's what it takes to have them fixed, e.g. the tag score that isn't updating for a month on SO. ;) Jan 15 at 21:10

2 Answers 2

8

Thanks for the report. The team is aware and working on fixing the issues. I'll edit this post once it's fixed.


Update: Since December 2023, we have been testing and slowly implementing our updated Cookie Consent modal for UK/EEA users in order to remain GDPR and IAB TCF compliant. As part of these changes, the Cookie Policy page accidentally went down for some time, but has been fixed and is now working as intended.

0
5

It appears the cookie page is not a page, but a window that has to pop-up in the existing page. This is what it looks like for me:

It is not a page. It is a window. Probably using JavaScript that half of the veterans have blocked already. This should have been made more obvious in the original statement. After all, it seems (I'm no expert but this is how it looks like to a user) it's not possible to halt the cookies while blocking JavaScript. That can't be the intention.


The link to the Cookie Settings appears to be relative. It will show as a link to the current page with an # appended.


You managed to find 2 bugs in 1 report: the Cookie Policy page fails to load and the Cookie Settings page only loads when loaded in the current window. It will not accept being loaded in a new tab.


For reference, this is what the (top part of) Stack Exchange Cookie Policy used to look like. Based on archival on The Wayback Machine, whatever broke it happened somewhere today. It was fine this morning.

1
  • 3
    Funny that people who block pop-ups don't get to choose their cookie settings. Maybe it would just be a whole lot easier if everyone was opted-out by default and sites only had to keep track (by cookie) of the people who opted in. The pop-up doesn't show up for me because my browser blocks the javascript as a tracker (I think).
    – ColleenV
    Jan 15 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .