9

For instance even on https://stackoverflow.com/ (just open it in browser private mode) I see cookie notice popup in Russian:

enter image description here

Possibly related to this Overlapped items on cookie customization popup

2
  • 5
    This smells more like it might be a feature (of the 3rd party cookie consent solution) than a bug. If your browser is sending an Accept-Language header which suggests your preferred language is ru-RU (IIRC you're a mod on ru.stackoverflow.com so that's well within the realms of possibility) then it's quite reasonable for something to present you with a Russian UI, if it can
    – Rob
    Feb 10 at 10:38
  • 1
    @Rob good point, but I also noticed that such cookie notices are different for different geographical areas. Post on ruSO.meta for instance. Feb 10 at 11:15

1 Answer 1

6

Thanks for the report. You should see the correct language now.


[UPDATE Mar 11] Changed this back to . Will update once resolved.


[UPDATE Mar 12] Issue confirmed resolved.

16
  • It is very funny. Looks like this fix isn't easy. Feb 14 at 20:36
  • @αλεχολυτ Did you try clearing your browser's cache before taking that screenshot? Feb 15 at 6:05
  • @SonictheAnonymousHedgehog no. Is it needed? Because on enSO problem is fixed for me. But it appears on MSE. Update: even on enSO I see cookie notice in Russian. Feb 15 at 7:00
  • What's the "Correct" language, then? The site's language, or the language the browser is requesting using Accept-Language headers? I would argue that displaying the popup in the language the browser requests would be preferable, as that's apparently the language the user is most comfortable with.
    – Cerbrus
    Feb 15 at 10:25
  • @Cerbrus doesn't matter, the answer is wrong and misleading. Feb 18 at 20:34
  • No, @ShadowWizardLoveZelda it does matter. If "Correct language" is browser language, then the answer is correct...
    – Cerbrus
    Feb 19 at 8:18
  • @Dalmarus, can you please clarify?
    – Cerbrus
    Feb 19 at 8:18
  • 1
    @Cerbrus The language seen in the cookies should be whichever language you have that particular Stack site set for. If the issue is still persisting, try clearing the browser cache and check again (or open an incognito tab and try). If it's still occurring after that, let me know and I'll have the team look into it further.
    – Dalmarus StaffMod
    Feb 22 at 13:47
  • 1
    @Dalmarus Thanks for the clarification. I can't reproduce this, as I only use English...
    – Cerbrus
    Feb 22 at 14:26
  • 1
    @Dalmarus I'm still seeing it in Russian in incognito mode on enSO. picture Mar 8 at 20:33
  • 1
    @αλεχολυτ Thanks. I've re-opened the issue with the team and will update the answer and tags here again once I have more info.
    – Dalmarus StaffMod
    Mar 11 at 11:04
  • 1
    @αλεχολυτ When you get a chance, let me know if you're still seeing it. Should be fixed now, but I'll wait a couple days to resolve this unless I hear back. Thanks again for flagging!
    – Dalmarus StaffMod
    Mar 11 at 16:55
  • 1
    It looks good now, English on enSO, Russian on ruSO, Portuguese on ptSO etc. Thanks for fixing. Mar 11 at 18:00
  • 1
    Great! Thanks for checking.
    – Dalmarus StaffMod
    Mar 12 at 13:31
  • @αλεχολυτ you forgot jaSO. ;) Mar 12 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .