4

I'm not able to reproduce this consistently, but often when I click on the last remaining unread notification in my inbox, it goes to the question but doesn't remove the count badge. So there's a "1" badge, but when I open the inbox there are no unread notifications. There's also no "Refresh", so it's not a case that new notifications have arrived but aren't shown yet.

6
  • 2
    Yes, this is a race condition between the page JavaScript and the browser destroying the current page's JavaScript context (and thus ending all processing, potentially terminating an AJAX request that may have been launched by JavaScript but not made it out of the browser/machine). It's been previously reported, either on MSO or MSE. As I recall, I previously posted one or more comments describing what's happening on the prior bug report.
    – Makyen
    Feb 14 at 18:32
  • I figured it probably would have been reported before, but I did some searches and didn't find it. Happy to have this closed as a dup.
    – Barmar
    Feb 14 at 18:34
  • 2
    Relevant MSO post with Makyen's excellent answer: Inbox notifications not consistently marked as read after clicking title
    – VLAZ
    Feb 14 at 18:34
  • @VLAZ Thanks. No wonder I couldn't find it when looking through my comments, as it wasn't a comment. :)
    – Makyen
    Feb 14 at 18:46
  • 2
    Related, possible duplicate: "I'm clicking the same message multiple times to get it to clear, is it broken, or is something else happening?", but that has quite a bit that's just confusion as to how the UI works.
    – Makyen
    Feb 14 at 18:48
  • @Makyen In my experience, the message itself clears, it's just the count badge that gets stuck.
    – Barmar
    Feb 14 at 20:24

0

You must log in to answer this question.

Browse other questions tagged .