22

Just received the weekly email from WebMasters, and the links are currently routing to an "Invalid Certificate" error:

Your connection isn't private

Attackers might be trying to steal your information from sg-links.stackoverflow.email (for example, passwords, messages or credit cards).

NET::ERR_CERT_COMMON_NAME_INVALID

This server couldn't prove that it's sg-links.stackoverflow.email; its security certificate is from *.sendgrid.net. This may be caused by a misconfiguration or an attacker intercepting your connection.

SSL Labs seems to agree that the certificate isn't currently valid for the domain. https://www.ssllabs.com/ssltest/analyze.html?d=sg%2dlinks.stackoverflow.email&latest

5
  • 8
    I, also, have recently encountered this issue when using a link which I'd received from SE.
    – Makyen
    Commented Jun 20 at 17:49
  • 2
    @Slate as this bug affects thousands of people every day who can't open links in the emails (well, they can, but most people will close right away a non secure link) any update on this? Commented Jun 24 at 10:22
  • 3
    I don't understand why this would be sitting in review for any length of time. Confirming the cert has expired should only take a minute, and fixing it shouldn't take long either. Commented Jun 25 at 18:46
  • It did appear to be resolved when a new version of the email was sent out the following day, so likely a transient issue. Commented Jul 2 at 6:54
  • @DanIsFiddlingByFirelight the issue wasn't necessarily that the cert has expired, but that for some reason the SendGrid servers weren't even attempting to send the matching cert. Commented Jul 2 at 6:56

0

You must log in to answer this question.

Browse other questions tagged .